summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-24 12:33:17 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-24 12:33:37 -0400
commit1feceeec046b975e842e9ed49bd5f507992d1e7b (patch)
tree02fed6a449d16d72e01452834652bab558ec9cb1 /dev-libs/mpfr
parentdev-python/django: x86 stable wrt bug #563776 (diff)
downloadgentoo-1feceeec046b975e842e9ed49bd5f507992d1e7b.tar.gz
gentoo-1feceeec046b975e842e9ed49bd5f507992d1e7b.tar.bz2
gentoo-1feceeec046b975e842e9ed49bd5f507992d1e7b.zip
dev-libs/mpfr: add multilib logic to older SLOT #563888
Diffstat (limited to 'dev-libs/mpfr')
-rw-r--r--dev-libs/mpfr/mpfr-2.4.2_p3-r1.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-libs/mpfr/mpfr-2.4.2_p3-r1.ebuild b/dev-libs/mpfr/mpfr-2.4.2_p3-r1.ebuild
index f97d812be714..0bfc14dd06f1 100644
--- a/dev-libs/mpfr/mpfr-2.4.2_p3-r1.ebuild
+++ b/dev-libs/mpfr/mpfr-2.4.2_p3-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# this ebuild is only for the libmpfr.so.1 ABI SONAME
-EAPI="4"
+EAPI="5"
-inherit eutils libtool flag-o-matic
+inherit eutils libtool multilib multilib-minimal flag-o-matic
MY_PV=${PV/_p*}
MY_P=${PN}-${MY_PV}
@@ -19,7 +19,7 @@ SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
-RDEPEND=">=dev-libs/gmp-4.1.4-r2"
+RDEPEND=">=dev-libs/gmp-4.1.4-r2:0[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
@@ -31,17 +31,20 @@ src_prepare() {
elibtoolize
}
-src_configure() {
+multilib_src_configure() {
# Newer gmp has deleted this define, so export it for older mpfr.
append-cppflags -D__gmp_const=const
+ # Make sure mpfr doesn't go probing toolchains it shouldn't #476336#19
+ ECONF_SOURCE=${S} \
+ user_redefine_cc=yes \
econf --disable-static
}
-src_compile() {
+multilib_src_compile() {
emake libmpfr.la
}
-src_install() {
- emake install-libLTLIBRARIES DESTDIR="${D}"
+multilib_src_install() {
+ emake DESTDIR="${D}" install-libLTLIBRARIES
rm -f "${ED}"/usr/*/libmpfr.{la,so,dylib,a}
}