summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-29 23:13:55 +0000
committerSam James <sam@gentoo.org>2020-09-29 23:13:55 +0000
commit594e23cf5d3e125eab53fd7b606e3fc27748787f (patch)
treea9c752b120126ecdd854a4bace000e2c81a1a8a4 /dev-libs/msgpack
parentwww-client/netsurf: Keyword 3.10-r3 arm, #728994 (diff)
downloadgentoo-594e23cf5d3e125eab53fd7b606e3fc27748787f.tar.gz
gentoo-594e23cf5d3e125eab53fd7b606e3fc27748787f.tar.bz2
gentoo-594e23cf5d3e125eab53fd7b606e3fc27748787f.zip
dev-libs/msgpack: bump to 3.3.0
Closes: https://bugs.gentoo.org/688936 Closes: https://bugs.gentoo.org/737586 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/msgpack')
-rw-r--r--dev-libs/msgpack/Manifest1
-rw-r--r--dev-libs/msgpack/msgpack-3.3.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/msgpack/Manifest b/dev-libs/msgpack/Manifest
index bcf4475f85ee..1f7dbe990d53 100644
--- a/dev-libs/msgpack/Manifest
+++ b/dev-libs/msgpack/Manifest
@@ -2,3 +2,4 @@ DIST msgpack-1.1.0.tar.gz 493551 BLAKE2B 3ee162fcba5ae61c7c69945a567ac4d39526e79
DIST msgpack-3.1.1.tar.gz 495858 BLAKE2B a99b7edb2a6de80e018d5c4084ea199518e34045a6293c622c8690147ae353abdb63856eb031962a02ce20903d4443ec2b01a3c033e756c339f8674ff801d4c3 SHA512 cc634ef38b3844bf994159024441fe72d99055c42b0a4d81245b0629fd1f3147587eb36537cfb85e4cae2edc1dc23d7fa400022efa5a10dca295f9a6acd38346
DIST msgpack-3.2.0.tar.gz 499188 BLAKE2B 6e5fd59a96ca726d3429b173b3db4c74163eaf6d314b289845237b6ace6208478dbbbb60397c630d515f6f6eed344b74f76225d1a4ca143b91ebb9b3a1369c14 SHA512 f3d011adfaa71b3c5d5f3eb43f0addbd461ae82b8ac22f367ddba7ef762d3bea500477501cf394d1770f0c47809bc363fc1088819ecfdfa668e93529885f4b88
DIST msgpack-3.2.1.tar.gz 1234733 BLAKE2B 97fb6cab5125463f10e7ad2c55ee478b2bf3dab5628a40ce1b0bcdd96cc002f5c99e495592c91f1342e6623d32b5594536de226b0bf80e1cb5290dae9b0566dc SHA512 68d06b05a1f00a3d9d7d39313a9e11f42828606c39d9d4c07673a48c9b88028a6316f2a964881cc8e4d185616a037711f02a7d3cd6029eadbacf52145603538b
+DIST msgpack-3.3.0.tar.gz 508001 BLAKE2B 3017c44689f8afbf078b9c498449e21b4e3b87591c50a37bf9ae73869dab550819f24d6e5179a3600df297aa2c024e5a7fe1defcbab7c0f1aff826870de2ab32 SHA512 ad3e32edc8c6afd70282b3d4b493c2ffe74a697c41bd1f39030c5b4752cccefaa965bc049d4c2e63103a210bf714dc3bddd474691bc067d1475ae017593f55e6
diff --git a/dev-libs/msgpack/msgpack-3.3.0.ebuild b/dev-libs/msgpack/msgpack-3.3.0.ebuild
new file mode 100644
index 000000000000..3d562eb7fed6
--- /dev/null
+++ b/dev-libs/msgpack/msgpack-3.3.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
+HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
+
+LICENSE="Boost-1.0"
+SLOT="0/2"
+IUSE="boost +cxx doc examples static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+RDEPEND="boost? ( dev-libs/boost[context,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ )
+"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DMSGPACK_BOOST="$(usex boost)"
+ -DMSGPACK_ENABLE_CXX="$(usex cxx)"
+ -DMSGPACK_ENABLE_STATIC="$(usex static-libs)"
+ -DMSGPACK_BUILD_TESTS="$(usex test)"
+ # don't build the examples
+ -DMSGPACK_BUILD_EXAMPLES=OFF
+ # enable C++11 by default
+ -DMSGPACK_CXX11=ON
+ )
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if multilib_is_native_abi && use doc; then
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ if use doc; then
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ mkdir docs || die
+ mv doc_c/html docs/c || die
+
+ use cxx && mv doc_cpp/html docs/cpp || die
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${WORKDIR}/${P}/example/."
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ fi
+
+ cmake_src_install
+}