summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-30 02:57:04 +0000
committerSam James <sam@gentoo.org>2020-09-30 02:57:04 +0000
commit82f8868fd9f42fd4573357ceeae4354d9647f0c2 (patch)
tree642eb8836620bd8deb2f2b8b672530494cdd3ab3 /dev-libs/msgpack
parentdev-libs/msgpack: Keyword 3.3.0 arm, #727138 (diff)
downloadgentoo-82f8868fd9f42fd4573357ceeae4354d9647f0c2.tar.gz
gentoo-82f8868fd9f42fd4573357ceeae4354d9647f0c2.tar.bz2
gentoo-82f8868fd9f42fd4573357ceeae4354d9647f0c2.zip
dev-libs/msgpack: cleanup old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/msgpack')
-rw-r--r--dev-libs/msgpack/Manifest3
-rw-r--r--dev-libs/msgpack/files/msgpack-1.0.0-cflags.patch25
-rw-r--r--dev-libs/msgpack/files/msgpack-1.0.0-static.patch40
-rw-r--r--dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch22
-rw-r--r--dev-libs/msgpack/msgpack-1.1.0.ebuild47
-rw-r--r--dev-libs/msgpack/msgpack-3.1.1.ebuild75
-rw-r--r--dev-libs/msgpack/msgpack-3.2.1.ebuild75
7 files changed, 0 insertions, 287 deletions
diff --git a/dev-libs/msgpack/Manifest b/dev-libs/msgpack/Manifest
index 1f7dbe990d53..d4d73cd4aaad 100644
--- a/dev-libs/msgpack/Manifest
+++ b/dev-libs/msgpack/Manifest
@@ -1,5 +1,2 @@
-DIST msgpack-1.1.0.tar.gz 493551 BLAKE2B 3ee162fcba5ae61c7c69945a567ac4d39526e7941f42cc2ed55bc5885b823af84eea212c4e75e8e8583e8ea8a5e12f75e969409193c5e7273430e2e02d33a02c SHA512 6823fab090c2146f871a45736c29b8f81434f0d72c597ebea2e947e4a9a17554e163bc88fbbc3dd0805b2ef0df029b10ca30c09dfbd1111252b9861a1e373901
-DIST msgpack-3.1.1.tar.gz 495858 BLAKE2B a99b7edb2a6de80e018d5c4084ea199518e34045a6293c622c8690147ae353abdb63856eb031962a02ce20903d4443ec2b01a3c033e756c339f8674ff801d4c3 SHA512 cc634ef38b3844bf994159024441fe72d99055c42b0a4d81245b0629fd1f3147587eb36537cfb85e4cae2edc1dc23d7fa400022efa5a10dca295f9a6acd38346
DIST msgpack-3.2.0.tar.gz 499188 BLAKE2B 6e5fd59a96ca726d3429b173b3db4c74163eaf6d314b289845237b6ace6208478dbbbb60397c630d515f6f6eed344b74f76225d1a4ca143b91ebb9b3a1369c14 SHA512 f3d011adfaa71b3c5d5f3eb43f0addbd461ae82b8ac22f367ddba7ef762d3bea500477501cf394d1770f0c47809bc363fc1088819ecfdfa668e93529885f4b88
-DIST msgpack-3.2.1.tar.gz 1234733 BLAKE2B 97fb6cab5125463f10e7ad2c55ee478b2bf3dab5628a40ce1b0bcdd96cc002f5c99e495592c91f1342e6623d32b5594536de226b0bf80e1cb5290dae9b0566dc SHA512 68d06b05a1f00a3d9d7d39313a9e11f42828606c39d9d4c07673a48c9b88028a6316f2a964881cc8e4d185616a037711f02a7d3cd6029eadbacf52145603538b
DIST msgpack-3.3.0.tar.gz 508001 BLAKE2B 3017c44689f8afbf078b9c498449e21b4e3b87591c50a37bf9ae73869dab550819f24d6e5179a3600df297aa2c024e5a7fe1defcbab7c0f1aff826870de2ab32 SHA512 ad3e32edc8c6afd70282b3d4b493c2ffe74a697c41bd1f39030c5b4752cccefaa965bc049d4c2e63103a210bf714dc3bddd474691bc067d1475ae017593f55e6
diff --git a/dev-libs/msgpack/files/msgpack-1.0.0-cflags.patch b/dev-libs/msgpack/files/msgpack-1.0.0-cflags.patch
deleted file mode 100644
index fc6cacd0a03c..000000000000
--- a/dev-libs/msgpack/files/msgpack-1.0.0-cflags.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- msgpack-1.0.0/CMakeLists.txt
-+++ msgpack-1.0.0/CMakeLists.txt
-@@ -213,10 +213,6 @@
- ADD_SUBDIRECTORY (test)
- ENDIF ()
-
--IF ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
-- SET_PROPERTY (TARGET msgpack APPEND_STRING PROPERTY COMPILE_FLAGS "-Wall -g -O3 -DPIC")
-- SET_PROPERTY (TARGET msgpack-static APPEND_STRING PROPERTY COMPILE_FLAGS "-Wall -g -O3" )
--ENDIF ()
- IF ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
- IF (CMAKE_CXX_FLAGS MATCHES "/W[0-4]")
- STRING(REGEX REPLACE "/W[0-4]" "/W3" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
---- msgpack-1.0.0/test/CMakeLists.txt
-+++ msgpack-1.0.0/test/CMakeLists.txt
-@@ -52,9 +52,6 @@
- ${CMAKE_THREAD_LIBS_INIT}
- )
- ADD_TEST (${source_file_we} ${source_file_we})
-- IF ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
-- SET_PROPERTY (TARGET ${source_file_we} APPEND_STRING PROPERTY COMPILE_FLAGS "-Wall -g -O3")
-- ENDIF ()
- IF ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "MSVC")
- IF (CMAKE_CXX_FLAGS MATCHES "/W[0-4]")
- STRING(REGEX REPLACE "/W[0-4]" "/W3" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
diff --git a/dev-libs/msgpack/files/msgpack-1.0.0-static.patch b/dev-libs/msgpack/files/msgpack-1.0.0-static.patch
deleted file mode 100644
index e40a9deaaece..000000000000
--- a/dev-libs/msgpack/files/msgpack-1.0.0-static.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- msgpack-1.0.0/CMakeLists.txt
-+++ msgpack-1.0.0/CMakeLists.txt
-@@ -17,6 +17,7 @@
-
- OPTION (MSGPACK_CXX11 "Using c++11 compiler" OFF)
- OPTION (MSGPACK_32BIT "32bit compile" OFF)
-+OPTION (MSGPACK_STATIC "Build static library" ON)
-
- IF (MSGPACK_CXX11)
- IF ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
-@@ -196,12 +197,15 @@
- ${msgpack_HEADERS}
- )
-
--ADD_LIBRARY (msgpack-static STATIC
-- ${msgpack_SOURCES}
-- ${msgpack_HEADERS}
--)
-+IF (MSGPACK_STATIC)
-+ ADD_LIBRARY (msgpack-static STATIC
-+ ${msgpack_SOURCES}
-+ ${msgpack_HEADERS}
-+ )
-+ SET_TARGET_PROPERTIES (msgpack-static PROPERTIES OUTPUT_NAME "msgpack")
-+ INSTALL (TARGETS msgpack-static DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+ENDIF ()
-
--SET_TARGET_PROPERTIES (msgpack-static PROPERTIES OUTPUT_NAME "msgpack")
- SET_TARGET_PROPERTIES (msgpack PROPERTIES IMPORT_SUFFIX "_import.lib")
- SET_TARGET_PROPERTIES (msgpack PROPERTIES SOVERSION 3 VERSION 4.0.0)
-
-@@ -233,7 +237,7 @@
- SET(CMAKE_INSTALL_LIBDIR lib)
- ENDIF ()
-
--INSTALL (TARGETS msgpack msgpack-static DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+INSTALL (TARGETS msgpack DESTINATION ${CMAKE_INSTALL_LIBDIR})
- INSTALL (DIRECTORY include DESTINATION ${CMAKE_INSTALL_PREFIX})
- INSTALL (FILES ${CMAKE_CURRENT_BINARY_DIR}/msgpack.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
diff --git a/dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch b/dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch
deleted file mode 100644
index 2fc9bb46e4bf..000000000000
--- a/dev-libs/msgpack/files/msgpack-1.1.0-gcc6.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Bug: https://bugs.gentoo.org/623492
-Backported from: https://github.com/msgpack/msgpack-c/commit/66a5fcf8f1a9e57b02904a6ac55a86a9c74ea1de
-
---- a/include/msgpack/adaptor/detail/cpp11_msgpack_tuple.hpp
-+++ b/include/msgpack/adaptor/detail/cpp11_msgpack_tuple.hpp
-@@ -46,13 +46,14 @@
- public:
- using base = std::tuple<Types...>;
-
-- using base::base;
-
-- tuple() = default;
- tuple(tuple const&) = default;
- tuple(tuple&&) = default;
-
- template<typename... OtherTypes>
-+ tuple(OtherTypes&&... other):base(std::forward<OtherTypes>(other)...) {}
-+
-+ template<typename... OtherTypes>
- tuple(tuple<OtherTypes...> const& other):base(static_cast<std::tuple<OtherTypes...> const&>(other)) {}
- template<typename... OtherTypes>
- tuple(tuple<OtherTypes...> && other):base(static_cast<std::tuple<OtherTypes...> &&>(other)) {}
diff --git a/dev-libs/msgpack/msgpack-1.1.0.ebuild b/dev-libs/msgpack/msgpack-1.1.0.ebuild
deleted file mode 100644
index 934638604a4a..000000000000
--- a/dev-libs/msgpack/msgpack-1.1.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
-HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+cxx static-libs test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]
- )
-"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.0-cflags.patch
- "${FILESDIR}"/${PN}-1.0.0-static.patch
- "${FILESDIR}"/${P}-gcc6.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DMSGPACK_ENABLE_CXX=$(usex cxx)
- -DMSGPACK_STATIC=$(usex static-libs)
- -DMSGPACK_BUILD_TESTS=$(usex test)
- )
-
- cmake-multilib_src_configure
-}
diff --git a/dev-libs/msgpack/msgpack-3.1.1.ebuild b/dev-libs/msgpack/msgpack-3.1.1.ebuild
deleted file mode 100644
index 9f05ddf33b7d..000000000000
--- a/dev-libs/msgpack/msgpack-3.1.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
-HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
-
-LICENSE="Boost-1.0"
-SLOT="0/2"
-IUSE="boost +cxx doc examples static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="boost? ( dev-libs/boost[context,${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]
- )
- doc? ( app-doc/doxygen[dot] )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DMSGPACK_BOOST="$(usex boost)"
- -DMSGPACK_ENABLE_CXX="$(usex cxx)"
- -DMSGPACK_ENABLE_STATIC="$(usex static-libs)"
- -DMSGPACK_BUILD_TESTS="$(usex test)"
- # don't build the examples
- -DMSGPACK_BUILD_EXAMPLES=OFF
- # enable C++11 by default
- -DMSGPACK_CXX11=ON
- )
- cmake-multilib_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
-
- if multilib_is_native_abi && use doc; then
- cmake-utils_src_make doxygen
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi; then
- if use doc; then
- local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
-
- mkdir docs || die
- mv doc_c/html docs/c || die
-
- use cxx && mv doc_cpp/html docs/cpp || die
- fi
-
- if use examples; then
- docinto examples
-
- dodoc -r "${WORKDIR}/${P}/example/."
-
- docompress -x /usr/share/doc/${PF}/examples
- fi
- fi
-
- cmake-utils_src_install
-}
diff --git a/dev-libs/msgpack/msgpack-3.2.1.ebuild b/dev-libs/msgpack/msgpack-3.2.1.ebuild
deleted file mode 100644
index a1129dcdc409..000000000000
--- a/dev-libs/msgpack/msgpack-3.2.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}-c.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}-c/releases/download/cpp-${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
-HOMEPAGE="https://msgpack.org/ https://github.com/msgpack/msgpack-c/"
-
-LICENSE="Boost-1.0"
-SLOT="0/2"
-IUSE="boost +cxx doc examples static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="boost? ( dev-libs/boost[context,${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
- sys-libs/zlib[${MULTILIB_USEDEP}]
- )
- doc? ( app-doc/doxygen[dot] )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DMSGPACK_BOOST="$(usex boost)"
- -DMSGPACK_ENABLE_CXX="$(usex cxx)"
- -DMSGPACK_ENABLE_STATIC="$(usex static-libs)"
- -DMSGPACK_BUILD_TESTS="$(usex test)"
- # don't build the examples
- -DMSGPACK_BUILD_EXAMPLES=OFF
- # enable C++11 by default
- -DMSGPACK_CXX11=ON
- )
- cmake-multilib_src_configure
-}
-
-multilib_src_compile() {
- cmake-utils_src_compile
-
- if multilib_is_native_abi && use doc; then
- cmake-utils_src_make doxygen
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi; then
- if use doc; then
- local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
-
- mkdir docs || die
- mv doc_c/html docs/c || die
-
- use cxx && mv doc_cpp/html docs/cpp || die
- fi
-
- if use examples; then
- docinto examples
-
- dodoc -r "${WORKDIR}/${P}/example/."
-
- docompress -x /usr/share/doc/${PF}/examples
- fi
- fi
-
- cmake-utils_src_install
-}