summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-25 16:06:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-25 16:07:04 +0200
commitb14db46f1a2f1408adc645882f2452232eb81f2d (patch)
tree6ba332740a6b46be0873e17dbdb0d3b553978ded /dev-libs/mxml
parentapp-portage/grs: do not install grsrun when USE=server (diff)
downloadgentoo-b14db46f1a2f1408adc645882f2452232eb81f2d.tar.gz
gentoo-b14db46f1a2f1408adc645882f2452232eb81f2d.tar.bz2
gentoo-b14db46f1a2f1408adc645882f2452232eb81f2d.zip
dev-libs/mxml: add 3.3.1
Bug: https://bugs.gentoo.org/860804 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/Manifest1
-rw-r--r--dev-libs/mxml/mxml-3.3.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index 1f5e1737dbcb..a9a6f2305cba 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1 +1,2 @@
+DIST mxml-3.3.1.tar.gz 1554784 BLAKE2B e0d599fd947dfef72edae40c1e70ea76c92105128dd46e772a7c71f9293cab3339c980396dffe105246cad64d0474935cc1939005ad9a2bffc8e8107f025a466 SHA512 43e6a92806d9c3f5db39fbf960c15ebfa6d92ef98274b7ce39b57724d6c26ad4362d6d8f3c1023efda92e6a815df068e5038a0cd479562b6be9dbdda8e827a41
DIST mxml-3.3.tar.gz 1550358 BLAKE2B 2b815cd8c2031099e2767caad93cc389962ec547fadade92b0a7fb48a2352fd0940c9e434c2081b7419e0cfb489266d7116dacefd6fb9d7ce40d6de0f49cb2a6 SHA512 5a8453bec17e46afc9b100df03dba2219353a076152f34a5dc41b7f042fa570723effc3472680a4380674c412c3ab31e017f6704b1e8308227a4d9b3f13cb197
diff --git a/dev-libs/mxml/mxml-3.3.1.ebuild b/dev-libs/mxml/mxml-3.3.1.ebuild
new file mode 100644
index 000000000000..e13435a875f2
--- /dev/null
+++ b/dev-libs/mxml/mxml-3.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs threads"
+
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+
+ # Build only static-libs, when requested by user, also build docs without static-libs in that case
+ if ! use static-libs; then
+ local mysedopts=(
+ -e '/^install:/s/install-libmxml.a//g'
+ -e '/^mxml.xml:/s/-static//g'
+ -e '/^mxml.epub:/s/-static//g'
+ -e '/^valgrind/s/-static//g'
+ -e 's/.\/mxmldoc-static/LD_LIBRARY_PATH="." .\/mxmldoc/g'
+ )
+ sed "${mysedopts[@]}" -i Makefile.in || die
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake testmxml
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}