summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-04-26 21:57:20 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-04-26 22:09:02 +0200
commitb96ea139e1d9fdf014fab6482fb859689a9599bf (patch)
treeebbfcc4f6ff6fa5c23638fb2f841288007b145f5 /dev-libs/ncnn/ncnn-20200413.ebuild
parentdev-python/argcomplete: Require non-ancient dev-python/pip for tests (diff)
downloadgentoo-b96ea139e1d9fdf014fab6482fb859689a9599bf.tar.gz
gentoo-b96ea139e1d9fdf014fab6482fb859689a9599bf.tar.bz2
gentoo-b96ea139e1d9fdf014fab6482fb859689a9599bf.zip
dev-libs/ncnn-20200413: version bump.
Tests disabled due to fact that they actually uses real GPU, which is bad on itself, and libsnadbox does not allow it too. Closes: https://bugs.gentoo.org/716154 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'dev-libs/ncnn/ncnn-20200413.ebuild')
-rw-r--r--dev-libs/ncnn/ncnn-20200413.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/ncnn/ncnn-20200413.ebuild b/dev-libs/ncnn/ncnn-20200413.ebuild
new file mode 100644
index 000000000000..efda01091014
--- /dev/null
+++ b/dev-libs/ncnn/ncnn-20200413.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A high-performance neural network inference framework"
+HOMEPAGE="https://github.com/Tencent/ncnn"
+
+SRC_URI="https://github.com/Tencent/ncnn/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-util/glslang
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader"
+
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+RESTRICT=test # Tests tries to use real GPU.
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_TOOLCHAIN_FILE="${S}/toolchains/host.gcc.toolchain.cmake"
+ -DNCNN_BUILD_EXAMPLES=OFF
+ -DNCNN_BUILD_TOOLS=OFF
+ -DNCNN_VULKAN=ON
+ )
+
+ cmake_src_configure
+}