summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-07 11:33:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-07 11:35:42 +0100
commitdded2cf741f9a681e819a5b6a9cef5c90676e6c5 (patch)
tree4c1a783b362d8c38a13a4f56a1c8ea59763d8efa /dev-libs/nsync/nsync-1.20.1.ebuild
parentpackage.mask: Last rite dev-ml/ocaml-cohttp (diff)
downloadgentoo-dded2cf741f9a681e819a5b6a9cef5c90676e6c5.tar.gz
gentoo-dded2cf741f9a681e819a5b6a9cef5c90676e6c5.tar.bz2
gentoo-dded2cf741f9a681e819a5b6a9cef5c90676e6c5.zip
dev-libs/nsync: EAPI-7 bump, use cmake.eclass for 1.20.1 too
Bug: https://bugs.gentoo.org/770580 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/nsync/nsync-1.20.1.ebuild')
-rw-r--r--dev-libs/nsync/nsync-1.20.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/nsync/nsync-1.20.1.ebuild b/dev-libs/nsync/nsync-1.20.1.ebuild
index c30d1d46e540..f71c5b73ae19 100644
--- a/dev-libs/nsync/nsync-1.20.1.ebuild
+++ b/dev-libs/nsync/nsync-1.20.1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
-DESCRIPTION="A C library that exports various synchronization primitives, such as mutexes"
+DESCRIPTION="C library that exports various synchronization primitives, such as mutexes"
HOMEPAGE="https://github.com/google/nsync"
SRC_URI="https://github.com/google/nsync/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -13,15 +14,14 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
+
RESTRICT="!test? ( test )"
DOCS=( README )
multilib_src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-DNSYNC_ENABLE_TESTS=$(usex test)
)
-
- cmake-utils_src_configure
+ cmake_src_configure
}