summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2021-04-16 00:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2021-04-16 12:59:05 -0400
commit8b075016bd3ca9f1a601abee6481c12b6fa31d2c (patch)
tree9cc8e66df462e3c7d049464e77d7bba873f66dd5 /dev-libs/oniguruma
parentmedia-video/totem: Version bump to 3.38.0 (diff)
downloadgentoo-8b075016bd3ca9f1a601abee6481c12b6fa31d2c.tar.gz
gentoo-8b075016bd3ca9f1a601abee6481c12b6fa31d2c.tar.bz2
gentoo-8b075016bd3ca9f1a601abee6481c12b6fa31d2c.zip
dev-libs/oniguruma: Version bump (6.9.7).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/oniguruma')
-rw-r--r--dev-libs/oniguruma/Manifest1
-rw-r--r--dev-libs/oniguruma/oniguruma-6.9.7.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/oniguruma/Manifest b/dev-libs/oniguruma/Manifest
index c774950ca538..e64dc4eea27e 100644
--- a/dev-libs/oniguruma/Manifest
+++ b/dev-libs/oniguruma/Manifest
@@ -1 +1,2 @@
DIST onig-6.9.6.tar.gz 926459 BLAKE2B 7a5fb49b35abe11fb91e7e4529855411fa0eb357897a2b327ddb5696a2c1e5f9fe7eb653fe84dbaeeff9c77e5489fd042d65e84f5b8e3e907bd30d60a0b75914 SHA512 eb44f70347f49945fe054ad65370dbfd6b30b2e8442fb90b6c72413b7f9a8cb77ca98d1a4714d1d32b763551430436cc0175c0efaf2c73268363a9b6ecb5e3bc
+DIST onig-6.9.7.tar.gz 935733 BLAKE2B dcabf46429ba1a99fb3c645144ee68cba2594ae30972dbfedc229eaca0686c32b776688218c68564a8c24f9f782f84901cd81bca01e2126ec39c742c002a517c SHA512 eba6057f87ef5897fe72d4535942e005329ec532db2f4cf8d5e901c478c151eedf3886ce04d595c406e2d5ad98273c0c2696eb46da5ee359b24f8221531e1f5a
diff --git a/dev-libs/oniguruma/oniguruma-6.9.7.ebuild b/dev-libs/oniguruma/oniguruma-6.9.7.ebuild
new file mode 100644
index 000000000000..a600340da373
--- /dev/null
+++ b/dev-libs/oniguruma/oniguruma-6.9.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2003-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit autotools git-r3
+
+ EGIT_REPO_URI="https://github.com/kkos/oniguruma"
+fi
+
+DESCRIPTION="Regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/onig-${PV}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="crnl-as-line-terminator static-libs"
+
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/onig-${PV}"
+fi
+
+DOCS=(AUTHORS HISTORY README{,_japanese} doc/{API,CALLOUTS.API,CALLOUTS.BUILTIN,FAQ,RE}{,.ja} doc/{SYNTAX.md,UNICODE_PROPERTIES})
+
+src_prepare() {
+ default
+
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-posix-api \
+ $(use_enable crnl-as-line-terminator) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name "*.la" -delete || die
+}