summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 00:07:15 +0000
committerSam James <sam@gentoo.org>2021-02-27 01:00:08 +0000
commit225b37c8a1637ca47d736063637c0231014a89b3 (patch)
tree0c2b4afe345ef9b8729e51574bb5f859fa6d8e2c /dev-libs/papi
parentdev-libs/papi: EAPI 7, fix libdir (diff)
downloadgentoo-225b37c8a1637ca47d736063637c0231014a89b3.tar.gz
gentoo-225b37c8a1637ca47d736063637c0231014a89b3.tar.bz2
gentoo-225b37c8a1637ca47d736063637c0231014a89b3.zip
dev-libs/papi: bump to 6.0.0.1
Closes: https://bugs.gentoo.org/681582 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/papi')
-rw-r--r--dev-libs/papi/Manifest1
-rw-r--r--dev-libs/papi/papi-6.0.0.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/papi/Manifest b/dev-libs/papi/Manifest
index 2ca09701fd23..456133e12639 100644
--- a/dev-libs/papi/Manifest
+++ b/dev-libs/papi/Manifest
@@ -1 +1,2 @@
DIST papi-5.5.1.tar.gz 4233127 BLAKE2B e065bed5a5607bf5ce3459ea84e1dabd6a60cd1f78f3ec2fbed29676ff79a057c77bd4210b8c45428238d927016a5a1e16d7bdfb4a9f56ea1e180cb0b19ec182 SHA512 c65c3a4e95c33ee7ceb950c184c08019d83cfee38bfe1bac86e80670a5191918edab2916b6815b15001da961deb8b6cf51263541554eb92a817e1a48371cfcf5
+DIST papi-6.0.0.1.tar.gz 4665285 BLAKE2B 5b6b2de8c16510a05a57159ceba591625c78f2a6d4ea62979fea4dd3e72bce73138e36480d82e13713c9ff2298e00330619fa57fdc7f81d75e1ce519b6f600ae SHA512 54c37b49858e921bd1357d8b0bba12c27e40e89b1354d89e5a85672ef3e6d3a4784212079098004256369a172d744580fb283741e7b4ac2d6fa5642bc42ea2ad
diff --git a/dev-libs/papi/papi-6.0.0.1.ebuild b/dev-libs/papi/papi-6.0.0.1.ebuild
new file mode 100644
index 000000000000..1001a71a638f
--- /dev/null
+++ b/dev-libs/papi/papi-6.0.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2 toolchain-funcs
+
+DESCRIPTION="Performance Application Programming Interface"
+HOMEPAGE="http://icl.cs.utk.edu/papi/"
+SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/libpfm
+ virtual/mpi
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+
+ # TODO: Could try adding
+ # --with-static-user-events=no
+ # --with-static-papi-events=no
+ # --with-static-lib=no
+ # --with-static-tools=no
+ # but this requires fixing the homebrew configure logic for
+ # little gain
+ local myeconfargs=(
+ --with-perf-events
+ --with-pfm-prefix="${EPREFIX}/usr"
+ --with-pfm-libdir="${EPREFIX}/usr/$(get_libdir)"
+ )
+
+ CONFIG_SHELL="${EPREFIX}/bin/bash" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc ../RE*
+}