summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/papi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/papi')
-rw-r--r--dev-libs/papi/Manifest2
-rw-r--r--dev-libs/papi/metadata.xml7
-rw-r--r--dev-libs/papi/papi-5.3.0.ebuild39
-rw-r--r--dev-libs/papi/papi-5.4.0.ebuild39
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/papi/Manifest b/dev-libs/papi/Manifest
new file mode 100644
index 000000000000..6bae30620498
--- /dev/null
+++ b/dev-libs/papi/Manifest
@@ -0,0 +1,2 @@
+DIST papi-5.3.0.tar.gz 3928589 SHA256 99f2f36398b370e75d100b4a189d5bc0ac4f5dd66df44d441f88fd32e1421524 SHA512 a88d28d895a1b44b0d05ac90c39406b7e9806a1d865b39df405e55b27d7f6bb191330ed7df52d4f3f04f46ff94ce867e6c1bdd9b38c314652cff1ee9d838b226 WHIRLPOOL cf1074f259831283292b57b636b6b0083a11ec6084bce2361eabe3ca706fd3d2420d3ab4074c8024296b06d11223a1dcc9782040ab08502481498b84bb2517e6
+DIST papi-5.4.0.tar.gz 4075657 SHA256 537bc209ad05050399d5f268ba8f40e499f457cab9b3503f57600f9893819195 SHA512 be4a929208a83765f99f2f34e98d6770bf46d4f336e492506cc86d6a34fbf84754b05cfd22db0949b382bb8f24ad0ed7f5e7c90941baad2593b82827ee27eb4a WHIRLPOOL 291d087c23b30a5f9f696771b62204ebe030ab731c35b9613a7821d110b920fcef777b0cfbbd136fe3838acf14631527055e0cf0c99624dfbbcd7c40cc4f4d99
diff --git a/dev-libs/papi/metadata.xml b/dev-libs/papi/metadata.xml
new file mode 100644
index 000000000000..1847f17d2266
--- /dev/null
+++ b/dev-libs/papi/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/papi/papi-5.3.0.ebuild b/dev-libs/papi/papi-5.3.0.ebuild
new file mode 100644
index 000000000000..1c32b5e29037
--- /dev/null
+++ b/dev-libs/papi/papi-5.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils fortran-2 versionator
+
+DESCRIPTION="Performance Application Programming Interface"
+HOMEPAGE="http://icl.cs.utk.edu/papi/"
+SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/libpfm[static-libs]
+ virtual/mpi
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
+
+src_configure() {
+ local myeconfargs=(
+ --with-shlib
+ --with-perf-events
+ --with-pfm-prefix="${EPREFIX}/usr"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc ../RE*
+}
diff --git a/dev-libs/papi/papi-5.4.0.ebuild b/dev-libs/papi/papi-5.4.0.ebuild
new file mode 100644
index 000000000000..9ed3357af1cb
--- /dev/null
+++ b/dev-libs/papi/papi-5.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils fortran-2 versionator
+
+DESCRIPTION="Performance Application Programming Interface"
+HOMEPAGE="http://icl.cs.utk.edu/papi/"
+SRC_URI="http://icl.cs.utk.edu/projects/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/libpfm[static-libs]
+ virtual/mpi
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)/src"
+
+src_configure() {
+ local myeconfargs=(
+ --with-shlib
+ --with-perf-events
+ --with-pfm-prefix="${EPREFIX}/usr"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc ../RE*
+}