summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-02-25 15:02:31 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-02-25 16:43:01 -0800
commit64840620f651b349780d307947c2740822769523 (patch)
tree492e1d0b249f5523307853dd34668d390a5746b1 /dev-libs/pmdk/pmdk-1.9.2.ebuild
parentsys-block/libfabric: New package (diff)
downloadgentoo-64840620f651b349780d307947c2740822769523.tar.gz
gentoo-64840620f651b349780d307947c2740822769523.tar.bz2
gentoo-64840620f651b349780d307947c2740822769523.zip
dev-libs/pmdk: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/pmdk/pmdk-1.9.2.ebuild')
-rw-r--r--dev-libs/pmdk/pmdk-1.9.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/pmdk/pmdk-1.9.2.ebuild b/dev-libs/pmdk/pmdk-1.9.2.ebuild
new file mode 100644
index 000000000000..245e99c6fe18
--- /dev/null
+++ b/dev-libs/pmdk/pmdk-1.9.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Persistent Memory Development Kit"
+HOMEPAGE="https://pmem.io/ https://github.com/pmem/pmdk"
+SRC_URI="https://github.com/pmem/pmdk/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/1"
+KEYWORDS="~amd64"
+
+DEPEND="
+ sys-block/ndctl:=
+ sys-block/libfabric:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ app-text/pandoc
+ virtual/pkgconfig
+"
+
+DOCS=(
+ CODING_STYLE.md
+ CONTRIBUTING.md
+ ChangeLog
+ README.md
+)
+
+src_prepare() {
+ default
+
+ # don't pre-compress man pages
+ sed -e 's/:=.gz//g ; s:gzip -nc:cat:g' -i doc/Makefile || die
+
+ # remove -Werror
+ find . -name 'Makefile*' -type f -print | xargs sed 's:-Werror::g' -i || die
+}
+
+src_configure() {
+ # doesn't build with -mindirect-branch=thunk
+ filter-flags -mindirect-branch=thunk
+}
+
+src_compile() {
+ emake DEBUG= CC=$(tc-getCC) CXX=$(tc-getCXX) LD=$(tc-getLD) AR=$(tc-getAR)
+}
+
+src_install() {
+ emake install prefix=/usr sysconfdir=/etc DESTDIR="${ED}"
+}