summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-03-31 22:14:00 +1100
committerMichael Palimaka <kensington@gentoo.org>2019-03-31 22:14:17 +1100
commita1a68837a5e59deda2cb51441f3f24c7fc63f173 (patch)
tree02747efffd8a4a9fe585f41bbd855e1393a98b85 /dev-libs/qcustomplot
parentpackage.mask: Last rite sci-chemistry/ball (diff)
downloadgentoo-a1a68837a5e59deda2cb51441f3f24c7fc63f173.tar.gz
gentoo-a1a68837a5e59deda2cb51441f3f24c7fc63f173.tar.bz2
gentoo-a1a68837a5e59deda2cb51441f3f24c7fc63f173.zip
dev-libs/qcustomplot: version bump 2.0.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'dev-libs/qcustomplot')
-rw-r--r--dev-libs/qcustomplot/Manifest2
-rw-r--r--dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/qcustomplot/Manifest b/dev-libs/qcustomplot/Manifest
index 847e533f7beb..2f2a77d38dda 100644
--- a/dev-libs/qcustomplot/Manifest
+++ b/dev-libs/qcustomplot/Manifest
@@ -1,2 +1,4 @@
DIST qcustomplot-sharedlib-2.0.0.tar.gz 1949 BLAKE2B 6d2d1b7da0dbdb83485ce1a1b69b5d4270fa73af25240decd1764d0872065a7457252aac3b81ccc9d5cbcfe24f8ed67ff843f092b344065b8b0f26aa2c6bef14 SHA512 f4ba719287067c2bb999a6e4ffb3694b32b1d72867c396fee1834ba2916f2931eda07bbe25c4d2ea6f6af18bd78917660dc6eabd98f72c9da987ae288ed4e611
+DIST qcustomplot-sharedlib-2.0.1.tar.gz 1963 BLAKE2B 294877d929564767009a8a4409111408eda1eb4e0cc64b48e644d25f30ef18151c2df1f0c5caa4e95c5b75dd492e795f97077e47bb927ff9637a2da9a2ec757e SHA512 ce90540fca7226eac37746327e1939a9c7af38fc2595f385ed04d6d1f49560da08fb5fae15d1b9d22b6ba578583f70de8f89ef26796770d41bf599c1b15c535d
DIST qcustomplot-source-2.0.0.tar.gz 317398 BLAKE2B c2d587e06026789a164f16ffdd00d324172654b6953ace637815b022dc14cc96362cf4022512ec3feea3725a651c1af0f50f09d0ca1c5e86ebcfbe3f50aa3ff2 SHA512 66c648877ed0a14cf527ac8526788065f494119cc61993d20268a0046c8e6c5a1c73a61f50a73e6a39ec55435bc5f74c613ee21254293ddab34ba7c2484c4f5a
+DIST qcustomplot-source-2.0.1.tar.gz 319140 BLAKE2B 868133f5126eea0aa8f80d34272f854de93b60575e3eed1b52211bec5ed96886503ba5c7f15c6f0ff15f3f67e35db6e5333adfc7465cee40768a65ed1b7275da SHA512 b44abbd8fd95970a829bbb6e7becc0765e24bd8f05958c8c1223303b68fb4c0a64f503cf0a2fe4fc53957e6e61a6618500475cff3e81ed0ab387a9eada2c83a3
diff --git a/dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild b/dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild
new file mode 100644
index 000000000000..51051c6445ad
--- /dev/null
+++ b/dev-libs/qcustomplot/qcustomplot-2.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Qt C++ widget for plotting and data visualization"
+HOMEPAGE="https://www.qcustomplot.com/"
+SRC_URI="
+ https://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
+ https://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-source
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:../../::g' \
+ -e '/CONFIG/s:shared.*:shared:g' \
+ "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dolib.so lib${PN}*
+ doheader ${PN}.h
+ dodoc changelog.txt
+}