summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/qjson
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/qjson')
-rw-r--r--dev-libs/qjson/Manifest1
-rw-r--r--dev-libs/qjson/metadata.xml9
-rw-r--r--dev-libs/qjson/qjson-0.8.1-r1.ebuild47
-rw-r--r--dev-libs/qjson/qjson-0.8.1.ebuild41
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-libs/qjson/Manifest b/dev-libs/qjson/Manifest
new file mode 100644
index 000000000000..50d6cb872695
--- /dev/null
+++ b/dev-libs/qjson/Manifest
@@ -0,0 +1 @@
+DIST qjson-0.8.1.tar.bz2 64398 SHA256 cd4db5b956247c4991a9c3e95512da257cd2a6bd011357e363d02300afc814d9 SHA512 03e65bbdf6d397f77319867a03377deb419eac46ad91bc06abb7bc68d8f8f2e490db87d909ce51e065f22e5d201f1f73d57f72e14bc378580dbf40b855f1bc72 WHIRLPOOL 532245b3eaaed901bbf44c1d005b002b010b2b7568142fe1435521e4ed24cb52f76accea9f2a324ed19183c62c2f8bfb0c0a257bf808795fc25faa132766ac32
diff --git a/dev-libs/qjson/metadata.xml b/dev-libs/qjson/metadata.xml
new file mode 100644
index 000000000000..46f078ccb4a3
--- /dev/null
+++ b/dev-libs/qjson/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="github">flavio/qjson</remote-id>
+ <bugs-to>https://github.com/flavio/qjson/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/qjson/qjson-0.8.1-r1.ebuild b/dev-libs/qjson/qjson-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..71fde4570399
--- /dev/null
+++ b/dev-libs/qjson/qjson-0.8.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib multilib
+
+DESCRIPTION="A library for mapping JSON data to QVariant objects"
+HOMEPAGE="http://qjson.sourceforge.net"
+SRC_URI="mirror://github/flavio/qjson/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc test"
+
+RDEPEND=">=dev-qt/qtcore-4.8.6:4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( >=dev-qt/qttest-4.8.6:4[${MULTILIB_USEDEP}] )"
+
+DOCS=( ChangeLog README.md )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test QJSON_BUILD_TESTS)
+ -DQT_QMAKE_EXECUTABLE=/usr/$(get_libdir)/qt4/bin/qmake
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+ use doc && if is_final_abi; then
+ cd "${S}"/doc || die "Failed to move inside doc directory"
+ doxygen Doxyfile || die "Generating documentation failed"
+ fi
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ HTML_DOCS=( doc/html/ )
+ einstalldocs
+ fi
+}
diff --git a/dev-libs/qjson/qjson-0.8.1.ebuild b/dev-libs/qjson/qjson-0.8.1.ebuild
new file mode 100644
index 000000000000..1591cc112e2c
--- /dev/null
+++ b/dev-libs/qjson/qjson-0.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A library for mapping JSON data to QVariant objects"
+HOMEPAGE="http://qjson.sourceforge.net"
+SRC_URI="mirror://github/flavio/qjson/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc test"
+
+RDEPEND="dev-qt/qtcore:4"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-qt/qttest:4 )"
+
+DOCS=( ChangeLog README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test QJSON_BUILD_TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use doc; then
+ cd doc
+ doxygen Doxyfile || die "Generating documentation failed"
+ HTML_DOCS=( doc/html/ )
+ fi
+
+ cmake-utils_src_install
+}