summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/redland-bindings
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/redland-bindings')
-rw-r--r--dev-libs/redland-bindings/Manifest1
-rw-r--r--dev-libs/redland-bindings/metadata.xml5
-rw-r--r--dev-libs/redland-bindings/redland-bindings-1.0.14.1-r2.ebuild55
-rw-r--r--dev-libs/redland-bindings/redland-bindings-1.0.14.1.ebuild103
4 files changed, 164 insertions, 0 deletions
diff --git a/dev-libs/redland-bindings/Manifest b/dev-libs/redland-bindings/Manifest
new file mode 100644
index 000000000000..a0b1e59dcf8f
--- /dev/null
+++ b/dev-libs/redland-bindings/Manifest
@@ -0,0 +1 @@
+DIST redland-bindings-1.0.14.1.tar.gz 792557 SHA256 a8cc365fccf292c56d53341ecae57fe8727e5002e048ca25f6251b5e595aec40 SHA512 5e037a96f857c95bf4b9277d98c7de1fa41c4ba7e49e199eeb516458343587c796a10e857679c889406b22bca8617828a2bccd07c31b73f2366cdea39cefad15 WHIRLPOOL 7858ce69a6664a5b219696c6fc9c96233f6bcdeeca6f494f83f6cbfde2873687c22a5bae7e01ea4f8b5037046addd13259ebc216f903f1cacb09cdf64b2aa1ba
diff --git a/dev-libs/redland-bindings/metadata.xml b/dev-libs/redland-bindings/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/dev-libs/redland-bindings/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/dev-libs/redland-bindings/redland-bindings-1.0.14.1-r2.ebuild b/dev-libs/redland-bindings/redland-bindings-1.0.14.1-r2.ebuild
new file mode 100644
index 000000000000..9b67ddb1743f
--- /dev/null
+++ b/dev-libs/redland-bindings/redland-bindings-1.0.14.1-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-single-r1
+
+DESCRIPTION="Language bindings for Redland"
+HOMEPAGE="http://librdf.org/bindings/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~x86-linux ~ppc-macos"
+IUSE="lua perl python php ruby"
+
+RDEPEND=">=dev-libs/redland-1.0.14
+ lua? ( >=dev-lang/lua-5.1 )
+ perl? ( dev-lang/perl:= )
+ php? ( dev-lang/php )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby dev-ruby/log4r )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-lang/swig-2
+ sys-apps/sed"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_with lua) \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with php) \
+ $(use_with ruby)
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALLDIRS=vendor luadir=/usr/$(get_libdir)/lua/5.1 install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+ use python && python_optimize
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml {NEWS,README,RELEASE,TODO}.html
+}
diff --git a/dev-libs/redland-bindings/redland-bindings-1.0.14.1.ebuild b/dev-libs/redland-bindings/redland-bindings-1.0.14.1.ebuild
new file mode 100644
index 000000000000..e9278b2cd641
--- /dev/null
+++ b/dev-libs/redland-bindings/redland-bindings-1.0.14.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit multilib python
+
+DESCRIPTION="Language bindings for Redland"
+HOMEPAGE="http://librdf.org/bindings/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~x86-linux ~ppc-macos"
+IUSE="lua perl python php ruby"
+
+RDEPEND=">=dev-libs/redland-1.0.14
+ lua? ( >=dev-lang/lua-5.1 )
+ perl? ( dev-lang/perl )
+ php? ( dev-lang/php )
+ ruby? ( dev-lang/ruby dev-ruby/log4r )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-lang/swig-2
+ sys-apps/sed"
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_with lua) \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with php) \
+ $(use_with ruby)
+
+ # Python bindings are built/tested/installed manually.
+ sed -e "/^SUBDIRS =/s/ python//" -i Makefile
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_test() {
+ default
+
+ if use python; then
+ testing() {
+ emake \
+ PYTHON="$(PYTHON)" \
+ check
+ }
+ python_execute_function -s --source-dir python testing
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALLDIRS=vendor luadir=/usr/$(get_libdir)/lua/5.1 install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ dohtml {NEWS,README,RELEASE,TODO}.html
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize RDF.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup RDF.py
+}