summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-11-27 08:40:40 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-12-14 23:01:58 +0800
commitbdf07728f9bcc159aff0e383a7db9b20b15e2910 (patch)
treeec42f3f49ec766f113bf776fd07b4363159387d7 /dev-libs/rocm-opencl-runtime
parentdev-util/hip: include test suit. (diff)
downloadgentoo-bdf07728f9bcc159aff0e383a7db9b20b15e2910.tar.gz
gentoo-bdf07728f9bcc159aff0e383a7db9b20b15e2910.tar.bz2
gentoo-bdf07728f9bcc159aff0e383a7db9b20b15e2910.zip
dev-libs/rocm-opencl-runtime: call check_amdgpu() from rocm.eclass.
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-opencl-runtime')
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild (renamed from dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1.ebuild)21
1 files changed, 3 insertions, 18 deletions
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild
index 95b46bd4cf1b..47adc38490e0 100644
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1.ebuild
+++ b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit cmake edo flag-o-matic
+ROCM_SKIP_GLOBALS=1
+inherit cmake edo flag-o-matic rocm
DESCRIPTION="Radeon Open Compute OpenCL Compatible Runtime"
HOMEPAGE="https://github.com/ROCm-Developer-Tools/clr"
@@ -72,24 +73,8 @@ src_install() {
doins tools/cltrace/libcltrace.so
}
-# Copied from rocm.eclass. This ebuild does not need amdgpu_targets
-# USE_EXPANDS, so it should not inherit rocm.eclass; it only uses the
-# check_amdgpu function in src_test. Rename it to check-amdgpu to avoid
-# pkgcheck warning.
-check-amdgpu() {
- for device in /dev/kfd /dev/dri/render*; do
- addwrite ${device}
- if [[ ! -r ${device} || ! -w ${device} ]]; then
- eerror "Cannot read or write ${device}!"
- eerror "Make sure it is present and check the permission."
- ewarn "By default render group have access to it. Check if portage user is in render group."
- die "${device} inaccessible"
- fi
- done
-}
-
src_test() {
- check-amdgpu
+ check_amdgpu
cd "${BUILD_DIR}"/tests/ocltst || die
export OCL_ICD_FILENAMES="${BUILD_DIR}"/amdocl/libamdocl64.so
local instruction1="Please start an X server using amdgpu driver (not Xvfb!),"