summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-07-03 10:46:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-07-03 10:47:04 +0000
commitcbb1ec071fdd7c549f89419cabf8330e204bbc32 (patch)
tree151d7d54eb6c66a8316bcaf7a0a96254c7772429 /dev-libs/rocm-opencl-runtime
parentsci-libs/caffe2: add support for cuda (diff)
downloadgentoo-cbb1ec071fdd7c549f89419cabf8330e204bbc32.tar.gz
gentoo-cbb1ec071fdd7c549f89419cabf8330e204bbc32.tar.bz2
gentoo-cbb1ec071fdd7c549f89419cabf8330e204bbc32.zip
dev-libs/rocm-opencl-runtime: Re-enable gfx800 family of cards
Discussion upstream at https://github.com/RadeonOpenCompute/ROCm/issues/1659 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-opencl-runtime')
-rw-r--r--dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-5.0.2-enable-gfx800.patch16
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.0.2-r1.ebuild (renamed from dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.0.2.ebuild)3
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-5.0.2-enable-gfx800.patch b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-5.0.2-enable-gfx800.patch
new file mode 100644
index 000000000000..29482340295e
--- /dev/null
+++ b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-5.0.2-enable-gfx800.patch
@@ -0,0 +1,16 @@
+#From xuhuisheng
+#at https://github.com/RadeonOpenCompute/ROCm/issues/1659#issuecomment-1041026624
+
+diff --git a/utils/flags.hpp b/utils/flags.hpp
+index 8f0228cc..2eaa47c5 100644
+--- a/utils/flags.hpp
++++ b/utils/flags.hpp
+@@ -245,7 +245,7 @@ release(bool, ROC_SYSTEM_SCOPE_SIGNAL, true, \
+ "Enable system scope for signals (uses interrupts).") \
+ release(bool, ROC_SKIP_COPY_SYNC, false, \
+ "Skips copy syncs if runtime can predict the same engine.") \
+-release(bool, ROC_ENABLE_PRE_VEGA, false, \
++release(bool, ROC_ENABLE_PRE_VEGA, true, \
+ "Enable support of pre-vega ASICs in ROCm path") \
+ release(bool, HIP_FORCE_QUEUE_PROFILING, false, \
+ "Force command queue profiling by default") \
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.0.2.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.0.2-r1.ebuild
index a90a016047af..9c74aa789f97 100644
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.0.2.ebuild
+++ b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.0.2-r1.ebuild
@@ -45,7 +45,8 @@ src_prepare() {
local S="${S1}"
local CMAKE_USE_DIR="${S1}"
# Bug #753377
- local PATCHES=()
+ # patch re-enables accidentally disabled gfx8000 family
+ local PATCHES=("${FILESDIR}/${PN}-5.0.2-enable-gfx800.patch")
BUILD_DIR="${S1}_build" cmake_src_prepare
}