summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-24 14:48:47 -0400
committerCraig Andrews <candrews@gentoo.org>2019-08-07 13:38:45 -0400
commit735e70751a6ca277349ff68c86c754b3e8c36026 (patch)
tree610a8f61e91af8378295607677a7574e0653cfe0 /dev-libs/rocr-runtime
parentdev-libs/rocr-runtime: 2.6.0 version bump (diff)
downloadgentoo-735e70751a6ca277349ff68c86c754b3e8c36026.tar.gz
gentoo-735e70751a6ca277349ff68c86c754b3e8c36026.tar.bz2
gentoo-735e70751a6ca277349ff68c86c754b3e8c36026.zip
dev-libs/rocr-runtime: add -9999 version
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
new file mode 100644
index 000000000000..a31193337a6d
--- /dev/null
+++ b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCR-Runtime-roc-${PV}/src"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="sys-process/numactl"
+DEPEND="${RDEPEND}
+ dev-libs/roct-thunk-interface"
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}