summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-15 09:45:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-15 18:33:38 +0200
commit5f5fee3559f1963e259fc1a136c74da863e57631 (patch)
treeff1184a58ce25e21ae938adafdb15d92431334a7 /dev-libs/sdformat/sdformat-9.2.0.ebuild
parentdev-util/ignition-cmake: drop multilib here (diff)
downloadgentoo-5f5fee3559f1963e259fc1a136c74da863e57631.tar.gz
gentoo-5f5fee3559f1963e259fc1a136c74da863e57631.tar.bz2
gentoo-5f5fee3559f1963e259fc1a136c74da863e57631.zip
dev-libs/sdformat: bump to 9.2.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-libs/sdformat/sdformat-9.2.0.ebuild')
-rw-r--r--dev-libs/sdformat/sdformat-9.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/sdformat/sdformat-9.2.0.ebuild b/dev-libs/sdformat/sdformat-9.2.0.ebuild
new file mode 100644
index 000000000000..2e44e5b271f2
--- /dev/null
+++ b/dev-libs/sdformat/sdformat-9.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Simulation Description Format (SDF) parser"
+HOMEPAGE="http://sdformat.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/sdformat/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# subslot = libsdformat major
+SLOT="0/9"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/urdfdom-1:=
+ dev-libs/tinyxml
+ dev-libs/boost:=
+ sci-libs/ignition-math:6=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/ruby:*
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_configure() {
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ local mycmakeargs=(
+ "-DUSE_INTERNAL_URDF=OFF"
+ "-DUSE_EXTERNAL_TINYXML=ON"
+ )
+ cmake-utils_src_configure
+}