summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/serdisplib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/serdisplib')
-rw-r--r--dev-libs/serdisplib/Manifest1
-rw-r--r--dev-libs/serdisplib/metadata.xml14
-rw-r--r--dev-libs/serdisplib/serdisplib-1.97.9.ebuild32
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/serdisplib/Manifest b/dev-libs/serdisplib/Manifest
new file mode 100644
index 000000000000..7b7e9109a778
--- /dev/null
+++ b/dev-libs/serdisplib/Manifest
@@ -0,0 +1 @@
+DIST serdisplib-1.97.9.tar.gz 293190 SHA256 fe82ebe72731e91509083569dfe41a09e21632cc1211cdc4f76274f83ed218fa SHA512 ab45202fd1fd85b12f1ebf7a7e1a4575ad363f6faffd45949300840456e26dd521c70b67ff57c32e1ff6c0a9f2668b3be6a653afb57ba6da701fbae6e8db3118 WHIRLPOOL f5427445f07b48ce3b4aa00b4a8f5cfeaa5cfa2610b9c83e1c9eb712ac3d019e6027d599cdf2829bb23c9e8f9b670e43c14cea95b040f11e631f4071a4fc79aa
diff --git a/dev-libs/serdisplib/metadata.xml b/dev-libs/serdisplib/metadata.xml
new file mode 100644
index 000000000000..52b25a031ac8
--- /dev/null
+++ b/dev-libs/serdisplib/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Library to drive displays with built-in controllers connected to
+ a parallel port (and serial port for i2c-displays).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">serdisplib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/serdisplib/serdisplib-1.97.9.ebuild b/dev-libs/serdisplib/serdisplib-1.97.9.ebuild
new file mode 100644
index 000000000000..aa48f18afe69
--- /dev/null
+++ b/dev-libs/serdisplib/serdisplib-1.97.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Library to drive serial/parallel/usb displays with built-in controllers"
+HOMEPAGE="http://serdisplib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="sdl usb"
+
+DEPEND="media-libs/gd[jpeg,png]
+ sdl? ( media-libs/libsdl )
+ usb? ( virtual/libusb:0 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --prefix="${D}/usr" \
+ $(use_enable sdl libSDL) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS HISTORY README BUGS PINOUTS
+}