summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/snowball-stemmer/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/snowball-stemmer/files')
-rw-r--r--dev-libs/snowball-stemmer/files/libstemmer_c-shared-library.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/snowball-stemmer/files/libstemmer_c-shared-library.patch b/dev-libs/snowball-stemmer/files/libstemmer_c-shared-library.patch
new file mode 100644
index 000000000000..ca27fc517705
--- /dev/null
+++ b/dev-libs/snowball-stemmer/files/libstemmer_c-shared-library.patch
@@ -0,0 +1,23 @@
+--- /home/graaff/Desktop/Makefile 2009-11-06 01:57:50.000000000 +0100
++++ Makefile 2013-07-18 10:57:32.482149252 +0200
+@@ -1,9 +1,13 @@
+ include mkinc.mak
+-CFLAGS=-Iinclude
+-all: libstemmer.o stemwords
+-libstemmer.o: $(snowball_sources:.c=.o)
+- $(AR) -cru $@ $^
+-stemwords: examples/stemwords.o libstemmer.o
+- $(CC) -o $@ $^
++CFLAGS+=-Iinclude -fPIC
++all: libstemmer.so libstemmer.a stemwords
++libstemmer.so: $(snowball_sources:.c=.o)
++ $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,$@.0d -o $@.0d.0.0 $^
++ ln -s $@.0d.0.0 $@.0d
++ ln -s $@.0d.0.0 $@
++libstemmer.a: $(snowball_sources:.c=.o)
++ $(AR) -crs $@ $^
++stemwords: examples/stemwords.o libstemmer.so
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+ clean:
+- rm -f stemwords *.o src_c/*.o runtime/*.o libstemmer/*.o
++ rm -f stemwords libstemmer.so* libstemmer.a *.o src_c/*.o runtime/*.o libstemmer/*.o