summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-05-10 21:30:56 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-05-10 21:31:16 +0300
commit1b429456d05d99d44acd1475efb9414fba235812 (patch)
tree8ba4e98001e46534c26cde2f6eb4ba40d92dfa48 /dev-libs/softhsm
parentx11-base/xorg-server: Drop old versions (diff)
downloadgentoo-1b429456d05d99d44acd1475efb9414fba235812.tar.gz
gentoo-1b429456d05d99d44acd1475efb9414fba235812.tar.bz2
gentoo-1b429456d05d99d44acd1475efb9414fba235812.zip
dev-libs/softhsm: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/softhsm')
-rw-r--r--dev-libs/softhsm/Manifest1
-rw-r--r--dev-libs/softhsm/softhsm-2.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/softhsm/Manifest b/dev-libs/softhsm/Manifest
index c5b97747993c..100a03a31732 100644
--- a/dev-libs/softhsm/Manifest
+++ b/dev-libs/softhsm/Manifest
@@ -1 +1,2 @@
DIST softhsm-2.3.0.tar.gz 992417 BLAKE2B dcb462a7d50be465c306e2208d2d446879ec093ce3a3233e338ba4df3b29a4f70050cd10ff513bff70ef37f98341230d061d48273a6fc54b668804311cb11bf8 SHA512 ef9ee41aa6eaeeb004d4ff5c78ca6e00895cc47e36551025a4422806eee8eead985cfd28476a867761a810f6957b0759edaac769bcdedf4ad974e426cfefce0f
+DIST softhsm-2.4.0.tar.gz 1042566 BLAKE2B 01a0f4bdc589847c4a1f860c3e3f572644d874b11d7ab8e149e598fc123b75e898de9a46f73f5f2a107edcaeabdda29e4b9b6d54af5b95ad79a3c7b7b77b8bbf SHA512 f14f65de32206500f708523ee88d8d5e3d1fd40175f1a9cd24c7760c829e2de9dbcb05453022df8186836c49a57e4eae7f2e75ce6a5346a426114f4d610a8a84
diff --git a/dev-libs/softhsm/softhsm-2.4.0.ebuild b/dev-libs/softhsm/softhsm-2.4.0.ebuild
new file mode 100644
index 000000000000..419485df8258
--- /dev/null
+++ b/dev-libs/softhsm/softhsm-2.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="https://www.opendnssec.org/"
+SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bindist libressl migration-tool test"
+SLOT="2"
+LICENSE="BSD"
+
+RDEPEND="
+ sys-devel/gcc:=[cxx]
+ migration-tool? ( dev-db/sqlite:3 )
+ !libressl? ( dev-libs/openssl:=[bindist=] )
+ libressl? ( dev-libs/libressl )
+ !=dev-libs/softhsm-2.0.0:0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )
+"
+
+DOCS=(
+ NEWS
+ README.md
+)
+
+src_configure() {
+ econf \
+ --disable-static \
+ --localstatedir="${EROOT}var" \
+ --with-crypto-backend=openssl \
+ --disable-p11-kit \
+ $(use_enable !bindist ecc) \
+ $(use_enable !libressl gost) \
+ $(use_with migration-tool migrate)
+}
+
+src_install() {
+ default
+ keepdir "${EROOT}/var/lib/softhsm/tokens"
+ prune_libtool_files --modules
+}