summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2018-08-07 12:25:23 +0200
committerCraig Andrews <candrews@gentoo.org>2018-08-08 17:21:38 -0400
commit8b0c05c847d692cc5f6d6c47caa5b9f29a925b2c (patch)
treebe0cc18d277f5f34a0ff485a2f1b51676b2693e0 /dev-libs/spdlog
parentdev-python/pillow: Add ~arm keyword wrt bug #659320 (diff)
downloadgentoo-8b0c05c847d692cc5f6d6c47caa5b9f29a925b2c.tar.gz
gentoo-8b0c05c847d692cc5f6d6c47caa5b9f29a925b2c.tar.bz2
gentoo-8b0c05c847d692cc5f6d6c47caa5b9f29a925b2c.zip
dev-libs/spdlog: bump to 1.0.0
Closes: https://bugs.gentoo.org/662942
Diffstat (limited to 'dev-libs/spdlog')
-rw-r--r--dev-libs/spdlog/Manifest1
-rw-r--r--dev-libs/spdlog/files/spdlog-1.0.0-unbundle-fmt.patch29
-rw-r--r--dev-libs/spdlog/spdlog-1.0.0.ebuild39
-rw-r--r--dev-libs/spdlog/spdlog-9999.ebuild6
4 files changed, 72 insertions, 3 deletions
diff --git a/dev-libs/spdlog/Manifest b/dev-libs/spdlog/Manifest
index 3f7a4c11c29c..2291d1dbf3b8 100644
--- a/dev-libs/spdlog/Manifest
+++ b/dev-libs/spdlog/Manifest
@@ -1 +1,2 @@
DIST spdlog-0.17.0.tar.gz 172323 BLAKE2B 2ca821fb3da0ee82601dd9ef54ca155ffdf19ea1e51c6fbb7269a58bf7a662b5225c9ef7e4d8ccbe7a05c56aeefaad27ddc9cfe21a329f52490078ccd0fb2ce6 SHA512 c3d7c7b2d221b33ad4f4685207ff606d271635bd1ad7edab763a823880386f604d264343139f37b36a3e8654d6382dbed0d431556728676523e390b8fb4b2aef
+DIST spdlog-1.0.0.tar.gz 183855 BLAKE2B 30d54fef03a83f968cfebacf95a484ff397126771a7ea022556aebd07e2f7694af35b278f75ee24372283ff1428e21247fd4329794d64a65bd6220a93f21db3c SHA512 4d3cbc1926be513256b5837a53fce425f6d352bb4ab262074f205450cd4eadc09feea9dc8d8c03b3f1e9792bcfbcff414be79e51d58234f540946428bbd88cd1
diff --git a/dev-libs/spdlog/files/spdlog-1.0.0-unbundle-fmt.patch b/dev-libs/spdlog/files/spdlog-1.0.0-unbundle-fmt.patch
new file mode 100644
index 000000000000..9b04f276ba55
--- /dev/null
+++ b/dev-libs/spdlog/files/spdlog-1.0.0-unbundle-fmt.patch
@@ -0,0 +1,29 @@
+diff --git a/include/spdlog/fmt/fmt.h b/include/spdlog/fmt/fmt.h
+--- a/include/spdlog/fmt/fmt.h
++++ b/include/spdlog/fmt/fmt.h
+@@ -16,10 +16,7 @@
+ #endif
+ #ifndef FMT_USE_WINDOWS_H
+ #define FMT_USE_WINDOWS_H 0
+-#endif
+-#include "bundled/core.h"
+-#include "bundled/format.h"
+-#else // external fmtlib
++#endif // external fmtlib
+ #include <fmt/core.h>
+ #include <fmt/format.h>
+ #endif
+diff --git a/include/spdlog/fmt/ostr.h b/include/spdlog/fmt/ostr.h
+--- a/include/spdlog/fmt/ostr.h
++++ b/include/spdlog/fmt/ostr.h
+@@ -11,8 +11,6 @@
+ #ifndef FMT_HEADER_ONLY
+ #define FMT_HEADER_ONLY
+ #endif
+-#include "bundled/ostream.h"
+-#include "fmt.h"
+-#else
+-#include <fmt/ostream.h>
+ #endif
++
++#include <fmt/ostream.h>
diff --git a/dev-libs/spdlog/spdlog-1.0.0.ebuild b/dev-libs/spdlog/spdlog-1.0.0.ebuild
new file mode 100644
index 000000000000..03aaec9bd608
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library"
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="test"
+
+DEPEND="
+ >=dev-libs/libfmt-5.0.0
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
+
+src_configure() {
+ rm -r include/spdlog/fmt/bundled || die
+
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_TESTING=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/spdlog/spdlog-9999.ebuild b/dev-libs/spdlog/spdlog-9999.ebuild
index e42aaade7db6..03aaec9bd608 100644
--- a/dev-libs/spdlog/spdlog-9999.ebuild
+++ b/dev-libs/spdlog/spdlog-9999.ebuild
@@ -17,15 +17,15 @@ else
fi
LICENSE="MIT"
-SLOT="0"
+SLOT="0/1"
IUSE="test"
DEPEND="
- <=dev-libs/libfmt-4.1.0
+ >=dev-libs/libfmt-5.0.0
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-0.17.0-unbundle-fmt.patch" )
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
src_configure() {
rm -r include/spdlog/fmt/bundled || die