summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-07-12 16:18:44 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-08 12:04:03 +0300
commitc680482145f31b0e20aae17bb9fbb2984e102aae (patch)
treec5741b1030fdd17cf75cb630e18e05e18dcbbc6b /dev-libs/spdlog
parentdev-ruby/did_you_mean: fix test deps (diff)
downloadgentoo-c680482145f31b0e20aae17bb9fbb2984e102aae.tar.gz
gentoo-c680482145f31b0e20aae17bb9fbb2984e102aae.tar.bz2
gentoo-c680482145f31b0e20aae17bb9fbb2984e102aae.zip
dev-libs/spdlog: fix tests segfault
Closes: https://bugs.gentoo.org/731238 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16678 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/spdlog')
-rw-r--r--dev-libs/spdlog/files/spdlog-1.6.1-tests-fix.patch13
-rw-r--r--dev-libs/spdlog/spdlog-1.6.1-r1.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-libs/spdlog/files/spdlog-1.6.1-tests-fix.patch b/dev-libs/spdlog/files/spdlog-1.6.1-tests-fix.patch
new file mode 100644
index 000000000000..8a6aa8020f7d
--- /dev/null
+++ b/dev-libs/spdlog/files/spdlog-1.6.1-tests-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/include/spdlog/fmt/bin_to_hex.h b/include/spdlog/fmt/bin_to_hex.h
+index e974cf51..5393dcac 100644
+--- a/include/spdlog/fmt/bin_to_hex.h
++++ b/include/spdlog/fmt/bin_to_hex.h
+@@ -92,7 +92,7 @@ struct formatter<spdlog::details::dump_info<T>>
+ auto parse(ParseContext &ctx) -> decltype(ctx.begin())
+ {
+ auto it = ctx.begin();
+- while (*it && *it != '}')
++ while (it != ctx.end() && *it != '}')
+ {
+ switch (*it)
+ {
diff --git a/dev-libs/spdlog/spdlog-1.6.1-r1.ebuild b/dev-libs/spdlog/spdlog-1.6.1-r1.ebuild
index 04237834f6cc..6d996c6f8eae 100644
--- a/dev-libs/spdlog/spdlog-1.6.1-r1.ebuild
+++ b/dev-libs/spdlog/spdlog-1.6.1-r1.ebuild
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-libfmt-7.0.0.patch"
+ "${FILESDIR}/${P}-tests-fix.patch"
)
src_prepare() {