summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-03 23:49:14 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-03 23:52:26 -0400
commit3aa4296812cda354ed706d4cadfd8aac5e96479d (patch)
tree0a94f105dacbe1d11bbc409c8b17330a76a7c51a /dev-libs/tinyxml2/tinyxml2-4.0.1.ebuild
parentwww-client/firefox-48: drop egl USE flag from gentoo-repo version, again. (diff)
downloadgentoo-3aa4296812cda354ed706d4cadfd8aac5e96479d.tar.gz
gentoo-3aa4296812cda354ed706d4cadfd8aac5e96479d.tar.bz2
gentoo-3aa4296812cda354ed706d4cadfd8aac5e96479d.zip
dev-libs/tinyxml2: version bump to 4.0.1
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-4.0.1.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-4.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-4.0.1.ebuild b/dev-libs/tinyxml2/tinyxml2-4.0.1.ebuild
new file mode 100644
index 000000000000..be9595903f8a
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-4.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-optional-tests.patch
+ "${FILESDIR}"/${P}-xmltest.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TEST=$(usex test)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test
+ ./xmltest || die "Tests failed"
+}