summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/tinyxml2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/tinyxml2')
-rw-r--r--dev-libs/tinyxml2/Manifest2
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch9
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch20
-rw-r--r--dev-libs/tinyxml2/metadata.xml8
-rw-r--r--dev-libs/tinyxml2/tinyxml2-1.0.9_p20121123.ebuild35
-rw-r--r--dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild33
6 files changed, 107 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/Manifest b/dev-libs/tinyxml2/Manifest
new file mode 100644
index 000000000000..6edb19da9512
--- /dev/null
+++ b/dev-libs/tinyxml2/Manifest
@@ -0,0 +1,2 @@
+DIST tinyxml2-1.0.9_p20121123.tar.bz2 91204 SHA256 894b6b1136c86cc98bff77892ca077726b470432e871ca8c8c605177047272ea SHA512 054342b51141771c7611ae5aeb6ea332c42dff603aa6747f802d02bd010cad4b5c84fadf976576d2a604f1cccc7afe95ff23682a98c9294b032c94aa48b09aaf WHIRLPOOL 9aa505e7794b1fe1919b185d2080e63f3b01f44d2daeba94b7da6701f4931ec9188c0f92c9db9c6e8ac02772ef85f582b3a5d64227fd7b353da0a258c8a72eb7
+DIST tinyxml2-2.2.0.tar.gz 455226 SHA256 f891224f32e7a06bf279290619cec80cc8ddc335c13696872195ffb87f5bce67 SHA512 e06edb46f96dcc58cf16c8fef91dd072c9bd6dd296bb9ba3e082db059438f5f31e0689015deee7f1c390788d9bd0e64b6f5c0235c9d2839419ee2ab1784f53c4 WHIRLPOOL 6310e1492b180cc1a74f856dbf78897c5db7777d44ffd5ef785f85fb87a91462479a9da006d93ad7157763416863ed623b14cfc8d99f35494335de7252cda754
diff --git a/dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch b/dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch
new file mode 100644
index 000000000000..49d7d8332e3b
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-1.0.1_p20120531-test-return-status.patch
@@ -0,0 +1,9 @@
+--- tinyxml2-1.0.1_p20120531/xmltest.cpp
++++ tinyxml2-1.0.1_p20120531/xmltest.cpp
+@@ -895,5 +895,5 @@
+ #endif
+
+ printf ("\nPass %d, Fail %d\n", gPass, gFail);
+- return 0;
++ return gFail;
+ }
diff --git a/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch b/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch
new file mode 100644
index 000000000000..a6842eecb6e5
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-1.0.9_p20121123-test.patch
@@ -0,0 +1,20 @@
+--- tinyxml2-1.0.9_p20121123/CMakeLists.txt
++++ tinyxml2-1.0.9_p20121123/CMakeLists.txt
+@@ -55,10 +55,13 @@
+ VERSION "${GENERIC_LIB_VERSION}"
+ SOVERSION "${GENERIC_LIB_SOVERSION}")
+
+-add_executable(test xmltest.cpp)
+-add_dependencies(test tinyxml2)
+-add_dependencies(test ${TARGET_DATA_COPY})
+-target_link_libraries(test tinyxml2)
++set(BUILD_TEST OFF CACHE BOOL "Set to ON to build tests")
++if(BUILD_TEST)
++ add_executable(test xmltest.cpp)
++ add_dependencies(test tinyxml2)
++ add_dependencies(test ${TARGET_DATA_COPY})
++ target_link_libraries(test tinyxml2)
++endif(BUILD_TEST)
+
+
+ if(BUILD_STATIC_LIBS)
diff --git a/dev-libs/tinyxml2/metadata.xml b/dev-libs/tinyxml2/metadata.xml
new file mode 100644
index 000000000000..4af0dabc8e1e
--- /dev/null
+++ b/dev-libs/tinyxml2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <upstream>
+ <remote-id type="github">leethomason/tinyxml2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/tinyxml2/tinyxml2-1.0.9_p20121123.ebuild b/dev-libs/tinyxml2/tinyxml2-1.0.9_p20121123.ebuild
new file mode 100644
index 000000000000..8c612dc75cbf
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-1.0.9_p20121123.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+CMAKE_MIN_VERSION="2.8.5"
+
+inherit cmake-utils
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/${PN}-1.0.1_p20120531-test-return-status.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build static-libs STATIC_LIBS)
+ $(cmake-utils_use_build test TEST)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test
+ ./test || die "Tests failed"
+}
diff --git a/dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild b/dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild
new file mode 100644
index 000000000000..2d2237a52f06
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/2"
+KEYWORDS="amd64 ~arm x86"
+IUSE="static-libs test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9_p20121123-test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build static-libs STATIC_LIBS)
+ $(cmake-utils_use_build test TEST)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test
+ ./test || die "Tests failed"
+}