summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/tntnet/tntnet-1.6.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/tntnet/tntnet-1.6.3.ebuild')
-rw-r--r--dev-libs/tntnet/tntnet-1.6.3.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/tntnet/tntnet-1.6.3.ebuild b/dev-libs/tntnet/tntnet-1.6.3.ebuild
new file mode 100644
index 000000000000..7b8904dfc19c
--- /dev/null
+++ b/dev-libs/tntnet/tntnet-1.6.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A modular, multithreaded webapplicationserver extensible with C++"
+HOMEPAGE="http://www.tntnet.org/"
+SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~sparc x86"
+IUSE="ssl gnutls examples"
+
+RDEPEND="=dev-libs/cxxtools-1*
+ sys-libs/zlib
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( dev-libs/openssl )
+ )"
+DEPEND="${RDEPEND}
+ app-arch/zip
+ ssl? ( gnutls? ( virtual/pkgconfig ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-gnutls-2.8.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+ if use ssl; then
+ if use gnutls; then
+ einfo "Using gnutls for ssl support."
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ einfo "Using openssl for ssl support."
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+ else
+ einfo "Disabled ssl"
+ myconf="${myconf} --with-ssl=no"
+ fi
+ if use examples; then
+ myconf="${myconf} --with-demos=yes"
+ else
+ myconf="${myconf} --with-demos=no"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO doc/*.pdf
+
+ if use examples; then
+ cd "${S}/sdk/demos"
+ make clean
+ rm -rf .deps */.deps .libs */.libs
+
+ local dir="/usr/share/doc/${PF}/examples"
+ dodir "${dir}"
+ cp -r "${S}"/sdk/demos/* "${D}${dir}"
+ fi
+}