summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-25 20:11:26 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-25 20:11:26 -0400
commit3122f370c4c1257536eca09844fcaa952092ed23 (patch)
tree2eaeb9c162c8fc386686f181d0e5aaa64e17b228 /dev-libs/tntnet
parentdev-libs/skyutils: add libressl support (diff)
downloadgentoo-3122f370c4c1257536eca09844fcaa952092ed23.tar.gz
gentoo-3122f370c4c1257536eca09844fcaa952092ed23.tar.bz2
gentoo-3122f370c4c1257536eca09844fcaa952092ed23.zip
dev-libs/tntnet: add libressl support
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/tntnet')
-rw-r--r--dev-libs/tntnet/tntnet-2.2.1-r1.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild b/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..43aae68c98f3
--- /dev/null
+++ b/dev-libs/tntnet/tntnet-2.2.1-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Modular, multithreaded webapplicationserver extensible with C++"
+HOMEPAGE="http://www.tntnet.org/"
+SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="doc gnutls libressl server ssl examples"
+
+RDEPEND=">=dev-libs/cxxtools-2.2.1
+ sys-libs/zlib[minizip]
+ ssl? (
+ gnutls? (
+ >=net-libs/gnutls-1.2.0
+ dev-libs/libgcrypt:0
+ )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/zip"
+
+src_prepare() {
+ # Both fixed in the next release
+ epatch "${FILESDIR}"/${PN}-2.0-zlib-minizip.patch
+ rm framework/common/{ioapi,unzip}.[ch] || die
+
+ # bug 423697
+ sed -e "s:unzip.h:minizip/unzip.h:" -i framework/defcomp/unzipcomp.cpp
+
+ eautoreconf
+
+ sed -i -e 's:@localstatedir@:/var:' etc/tntnet/tntnet.xml.in || die
+}
+
+src_configure() {
+ local myconf=""
+
+ # Prefer gnutls above SSL
+ if use gnutls; then
+ einfo "Using gnutls for ssl support."
+ myconf="${myconf} --with-ssl=gnutls"
+ elif use ssl; then
+ einfo "Using openssl for ssl support."
+ myconf="${myconf} --with-ssl=openssl"
+ else
+ myconf="${myconf} --with-ssl=no"
+ fi
+
+ # default enabled, will not compile without sdk
+ myconf="${myconf} --with-sdk"
+
+ econf \
+ $(use_with server) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+ if use doc; then
+ dodoc doc/*.pdf || die
+ fi
+
+ if use examples; then
+ cd "${S}/sdk/demos"
+ emake clean
+ rm -rf .deps */.deps .libs */.libs
+ cd "${S}"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r sdk/demos/* || die
+ fi
+
+ if use server; then
+ rm -f "${D}/etc/init.d/tntnet"
+ newinitd "${FILESDIR}/tntnet.initd" tntnet
+ fi
+}