summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/tre/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/tre/files')
-rw-r--r--dev-libs/tre/files/0.8.0-pkgcfg.patch14
-rw-r--r--dev-libs/tre/files/0.8.0-python.patch39
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/tre/files/0.8.0-pkgcfg.patch b/dev-libs/tre/files/0.8.0-pkgcfg.patch
new file mode 100644
index 000000000000..82f803504282
--- /dev/null
+++ b/dev-libs/tre/files/0.8.0-pkgcfg.patch
@@ -0,0 +1,14 @@
+ tre.pc.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tre.pc.in b/tre.pc.in
+index fdc45fa..b8d0676 100644
+--- a/tre.pc.in
++++ b/tre.pc.in
+@@ -6,5 +6,5 @@ includedir=@includedir@
+ Name: TRE
+ Description: TRE regexp matching library
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -ltre @LDFLAGS@ @LIBINTL@ @LIBS@
++Libs: -L${libdir} -ltre @LIBINTL@ @LIBS@
+ Cflags: -I${includedir} @CPPFLAGS@
diff --git a/dev-libs/tre/files/0.8.0-python.patch b/dev-libs/tre/files/0.8.0-python.patch
new file mode 100644
index 000000000000..f290e0bf5783
--- /dev/null
+++ b/dev-libs/tre/files/0.8.0-python.patch
@@ -0,0 +1,39 @@
+diff --git a/python/setup.py b/python/setup.py
+index b420a4c..b1bca6b 100644
+--- a/python/setup.py
++++ b/python/setup.py
+@@ -10,7 +10,8 @@ import shutil
+
+ version = "0.8.0"
+ data_files = []
+-include_dirs = ["../lib"]
++include_dirs = ["lib"]
++library_dirs = ["lib/.libs"]
+ libraries = ["tre"]
+
+ if sys.platform == "win32":
+@@ -28,9 +29,10 @@ setup(name = "tre",
+ url = "http://laurikari.net/tre/",
+ data_files = data_files,
+ ext_modules = [Extension("tre",
+- sources = ["tre-python.c"],
++ sources = ["python/tre-python.c"],
+ define_macros = [("HAVE_CONFIG_H", None)],
+ include_dirs = include_dirs,
++ library_dirs = library_dirs,
+ libraries = libraries
+ ),
+ ],
+diff --git a/python/tre-python.c b/python/tre-python.c
+index bbb24ed..2e35e3a 100644
+--- a/python/tre-python.c
++++ b/python/tre-python.c
+@@ -13,7 +13,7 @@
+ #include "Python.h"
+ #include "structmember.h"
+
+-#include <tre/tre.h>
++#include <tre.h>
+
+ #define TRE_MODULE "tre"
+