summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2019-06-12 14:04:40 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-05 16:23:57 +0200
commitf524f5217331b84965e484eded8b5271b907fb6b (patch)
treeeb4c1505d2037362dd1da0ef682bd36df45a5990 /dev-libs/tvision/tvision-2.2.1.4.ebuild
parentprofiles/prefix/darwin/macos/package.mask: update mask for CMake (diff)
downloadgentoo-f524f5217331b84965e484eded8b5271b907fb6b.tar.gz
gentoo-f524f5217331b84965e484eded8b5271b907fb6b.tar.bz2
gentoo-f524f5217331b84965e484eded8b5271b907fb6b.zip
dev-libs/tvision: fix gcc-7 incompatibilities
With gcc-7, they way overloaded functions are handled has changed, which led to build failures. This has been addressed by upstream, see https://sourceforge.net/p/tvision/bugs/17/ Closes: https://bugs.gentoo.org/639492 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12245 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/tvision/tvision-2.2.1.4.ebuild')
-rw-r--r--dev-libs/tvision/tvision-2.2.1.4.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-libs/tvision/tvision-2.2.1.4.ebuild b/dev-libs/tvision/tvision-2.2.1.4.ebuild
index 0e8e0a50a556..4cbbeea9403b 100644
--- a/dev-libs/tvision/tvision-2.2.1.4.ebuild
+++ b/dev-libs/tvision/tvision-2.2.1.4.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+MY_PV=$(ver_rs 3 -)
DESCRIPTION="Text User Interface that implements the well known CUA widgets"
HOMEPAGE="http://tvision.sourceforge.net/"
-MY_PVR=${PVR:0:5}-${PVR:6}
-SRC_URI="mirror://sourceforge/tvision/rhtvision_${MY_PVR}.tar.gz"
+SRC_URI="mirror://sourceforge/tvision/rhtvision_${MY_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -33,7 +34,7 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXmu
x11-libs/libXt
- x11-libs/libxcb
+ x11-libs/libxcb:=
)"
DEPEND="${RDEPEND}"
@@ -43,6 +44,7 @@ PATCHES=(
"${FILESDIR}/${P}-build-system.patch"
"${FILESDIR}/${P}-gcc6.patch"
"${FILESDIR}/${P}-flags.patch"
+ "${FILESDIR}/${P}-fix-overloaded-abs.patch"
)
src_configure() {
@@ -63,8 +65,5 @@ src_install() {
dosym rhtvision /usr/include/tvision
# remove CVS directory which gets copied over
- rm -rf "${ED%/}/usr/share/doc/${P}/html/CVS" || die
-
- # TODO: remove locales which are not needed, depending on current user
- # locale settings. How?
+ rm -r "${ED}/usr/share/doc/${P}/html/CVS" || die
}