summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/unibilium
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/unibilium')
-rw-r--r--dev-libs/unibilium/Manifest2
-rw-r--r--dev-libs/unibilium/metadata.xml8
-rw-r--r--dev-libs/unibilium/unibilium-1.1.2.ebuild30
-rw-r--r--dev-libs/unibilium/unibilium-1.1.4.ebuild30
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/unibilium/Manifest b/dev-libs/unibilium/Manifest
new file mode 100644
index 000000000000..a2923970215c
--- /dev/null
+++ b/dev-libs/unibilium/Manifest
@@ -0,0 +1,2 @@
+DIST unibilium-1.1.2.tar.xz 50076 SHA256 8c7ac52c31ac9567967891c3006bf8a677ec98eeaf46cc4acfc52efe9e165c3c SHA512 275146b0f4ad15997876180143938ff782f3be24c6fcfc2a0a3dbf22e19bfc6999f4c27ec6a39ebf8e45ad5cc0c3e5a80caa1ef00526bf54c824b78eaa0c29d4 WHIRLPOOL c50c816de331c0715191a1801e759facc968ff17a24b4a4d21ded9ab43acfbae4fe5693cfc08fd32ce0a46e2faa11211153cbf76f641931c0fbf197ad52934e8
+DIST unibilium-1.1.4.tar.xz 50828 SHA256 8866ca5695f624830bef081191e33ff359de4fc1f8a36604f7271d2a8807ca44 SHA512 fdd5c57d0b2e3dac7f2a19c4d332e0d6bfc2378ca6aeabb4504ad0cea6ff7e78d87d2ef9f4b5187b038cb4380803b7ad72105e4da7769b35fdc694882b4cb61b WHIRLPOOL 1561de875d92ed90ea6daef9fdee6548f3f30ebf2af3e9a01b87dce3ab8e92ed0b5d06890ac7e15d4b1f6399c19e7a768ec5e964cb7bb08c1df96a0d710096dd
diff --git a/dev-libs/unibilium/metadata.xml b/dev-libs/unibilium/metadata.xml
new file mode 100644
index 000000000000..dd59dfe14476
--- /dev/null
+++ b/dev-libs/unibilium/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">mauke/unibilium</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/unibilium/unibilium-1.1.2.ebuild b/dev-libs/unibilium/unibilium-1.1.2.ebuild
new file mode 100644
index 000000000000..2622ed7e4ca3
--- /dev/null
+++ b/dev-libs/unibilium/unibilium-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="A very basic terminfo library"
+HOMEPAGE="https://github.com/mauke/unibilium/"
+SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sys-devel/libtool"
+RDEPEND=""
+
+src_compile() {
+ append-flags -fPIC -fPIE
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" all
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+ prune_libtool_files
+}
diff --git a/dev-libs/unibilium/unibilium-1.1.4.ebuild b/dev-libs/unibilium/unibilium-1.1.4.ebuild
new file mode 100644
index 000000000000..cfcb332a4888
--- /dev/null
+++ b/dev-libs/unibilium/unibilium-1.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="A very basic terminfo library"
+HOMEPAGE="https://github.com/mauke/unibilium/"
+SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sys-devel/libtool"
+RDEPEND=""
+
+src_compile() {
+ append-flags -fPIC
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" all
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" install
+ prune_libtool_files
+}