summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2016-03-19 22:25:56 +0000
committerAnthony G. Basile <blueness@gentoo.org>2016-03-20 11:42:53 -0400
commitb8c46b00bb2391fb68bef9de6043c82e5b158163 (patch)
treef46bbfb3785f760c996ec99eb18d52f43dace5f2 /dev-libs/univalue/univalue-1.0.2.ebuild
parentdev-libs/libsecp256k1: bump to 0.0.0_pre20151118 and update 9999 (diff)
downloadgentoo-b8c46b00bb2391fb68bef9de6043c82e5b158163.tar.gz
gentoo-b8c46b00bb2391fb68bef9de6043c82e5b158163.tar.bz2
gentoo-b8c46b00bb2391fb68bef9de6043c82e5b158163.zip
dev-libs/univalue: initial commit, version 1.0.2
Diffstat (limited to 'dev-libs/univalue/univalue-1.0.2.ebuild')
-rw-r--r--dev-libs/univalue/univalue-1.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/univalue/univalue-1.0.2.ebuild b/dev-libs/univalue/univalue-1.0.2.ebuild
new file mode 100644
index 000000000000..29eec3575b6b
--- /dev/null
+++ b/dev-libs/univalue/univalue-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="C++ universal value object and JSON library"
+HOMEPAGE="https://github.com/jgarzik/univalue"
+LICENSE="MIT"
+
+SRC_URI="https://codeload.github.com/jgarzik/${PN}/tar.gz/v${PV} -> ${P}.tgz"
+SLOT="0/0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ./autogen.sh || die
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default_src_install
+ prune_libtool_files
+} \ No newline at end of file