summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-05-03 18:40:47 +0300
committerDavid Seifert <soap@gentoo.org>2017-05-04 18:58:38 +0200
commit279654802ae3c6c4d68faabb399383f5da1fa71d (patch)
tree1e8ec4620b076b80651a7b4a9695de05a2666c7e /dev-libs/wlc
parentdev-python/pretty-yaml: Add python3_6 (diff)
downloadgentoo-279654802ae3c6c4d68faabb399383f5da1fa71d.tar.gz
gentoo-279654802ae3c6c4d68faabb399383f5da1fa71d.tar.bz2
gentoo-279654802ae3c6c4d68faabb399383f5da1fa71d.zip
dev-libs/wlc: version bump to 0.0.9
Closes: https://github.com/gentoo/gentoo/pull/4542
Diffstat (limited to 'dev-libs/wlc')
-rw-r--r--dev-libs/wlc/Manifest1
-rw-r--r--dev-libs/wlc/wlc-0.0.9.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/wlc/Manifest b/dev-libs/wlc/Manifest
index 7f5503464f28..d31fb7b0bff5 100644
--- a/dev-libs/wlc/Manifest
+++ b/dev-libs/wlc/Manifest
@@ -1,2 +1,3 @@
DIST wlc-0.0.7.tar.bz2 234305 SHA256 47e9b756d3fd621df913a6fbc9378c47aa8f9c3be7c2228a657a2411a7211979 SHA512 19775e965d5fc6501be4fa004955e4403859dfbcfaa99897977f4ad3a13493c08a70f7e5c77a1ab76e892c3fa855658a37082bd077287ead08240888b7fc17f0 WHIRLPOOL 57c746a5331686b112920353dff8797a6fbaaca4c6241573659a54649c6214b2224d5dd0fad202574a1358fc06b5d8dcc47c563d216ad0333347a283564cc85f
DIST wlc-0.0.8.tar.bz2 236970 SHA256 1a7d7758028b0caa75418268f59e2290420850d0f3226ecf74316405d2c5ace5 SHA512 5ddf7dfc5115fa51ea078933b60c6e8ef9515db98f1c47d4ecfe3f49e07dbdadf2bbeb6f6002cc83d13098dee5fa7e66fcae211a58bd762ee984088aebadb779 WHIRLPOOL e99da312339bbc7b3c9c77dcec14b185132bb1216512f85e488cefc7b2b2108793fd7acaba0f172f753b4b38b7551c190758ed778514050a47262a808f86e80e
+DIST wlc-0.0.9.tar.bz2 240932 SHA256 cc239283c1d87aff9d258e0f4dd5a3ad441d8c6e52be8204abd8694435e4c3b5 SHA512 d34a29c779a39ffb95413f26c62d545f29ed7890529296b837bb153687600582dbe927c65558923bd1614c5fe904aa9cff760c272e79c6c0eff10ba38eee895b WHIRLPOOL 002eb60fbec28fdd599996b10daaa2c2f1b15ace077e4f80bd56c906e32a51cf47a58f6c0dcbb510f333a2fcd0dccf307f5e91cc0330418b09e7d5003c4960ea
diff --git a/dev-libs/wlc/wlc-0.0.9.ebuild b/dev-libs/wlc/wlc-0.0.9.ebuild
new file mode 100644
index 000000000000..44f42bf1f8ea
--- /dev/null
+++ b/dev-libs/wlc/wlc-0.0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A helper library for Wayland compositors"
+HOMEPAGE="https://github.com/Cloudef/wlc"
+
+SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X static-libs systemd xwayland"
+
+RDEPEND="virtual/opengl
+ virtual/libudev
+ media-libs/mesa[wayland,gbm,gles2,egl]
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon
+ x11-misc/xkeyboard-config
+ dev-libs/libinput
+ dev-libs/wayland
+ X? ( x11-libs/libX11
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/libXfixes )
+ xwayland? ( x11-base/xorg-server[wayland] )
+ systemd? ( sys-apps/systemd sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.7"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWLC_BUILD_EXAMPLES=OFF
+ -DWLC_BUILD_TESTS=OFF
+ -DWLC_BUILD_STATIC=$(usex static-libs)
+ -DWLC_X11_SUPPORT=$(usex X)
+ $(cmake-utils_use_find_package systemd Systemd)
+ $(cmake-utils_use_find_package systemd Dbus)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use X && ! use xwayland; then
+ elog "xwayland use flag is required for X11 applications support"
+ fi
+}