summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-11-21 19:48:32 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-21 20:16:30 +0100
commitdbcd40da66074578b78198ef8c5857ab932e9b6c (patch)
treee5180255f02c0c2f348be2b82bb8ae668d9a2a55 /dev-libs/wlc
parentnet-misc/chrony: Version bump. (diff)
downloadgentoo-dbcd40da66074578b78198ef8c5857ab932e9b6c.tar.gz
gentoo-dbcd40da66074578b78198ef8c5857ab932e9b6c.tar.bz2
gentoo-dbcd40da66074578b78198ef8c5857ab932e9b6c.zip
dev-libs/wlc: version bump to 0.0.7
Closes: https://github.com/gentoo/gentoo/pull/2883
Diffstat (limited to 'dev-libs/wlc')
-rw-r--r--dev-libs/wlc/Manifest1
-rw-r--r--dev-libs/wlc/wlc-0.0.7.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/wlc/Manifest b/dev-libs/wlc/Manifest
index 0eb90a1c911f..661664eb22e7 100644
--- a/dev-libs/wlc/Manifest
+++ b/dev-libs/wlc/Manifest
@@ -1,2 +1,3 @@
DIST wlc-0.0.5.tar.bz2 207900 SHA256 17aa8e8f4beb62b630433dd69247f272caf0575d2638726cfc1808a4239db136 SHA512 d5d0f299e713306b6c08e78b87ab8eaf9ff974aedd29b353c0db5a1a23602248306e7cd1918136f95663726fa028aa531bd496a7f24f5eaba8ba309e9af801f7 WHIRLPOOL 04f46251eac5dc21ec3071d46020819330452f61f7d60f4b9a3ac44104d0da8e65a8cd073d4a74968cb0bbf3eab57d13a62a09fd942a45157b470c2a89f742bc
DIST wlc-0.0.6.tar.bz2 234155 SHA256 302a14252757f05ed009077a674b07942ff46fc7c3da0759fed4fedbc8c12329 SHA512 944e3b34436618a1288488dcb8eb7ea2db46e32f73e4d07e4e896fe94cd0084857008f900257846098af4094bf5351bd7ec7d4c6aef427d0991922fd04049dc9 WHIRLPOOL a026a240edb1fa3d961f6fe765b5e30abfe448e2beb6c6623e8d95fa2640ffdc02b030c1f0fa8733fda235b541ca373c0e88bdbb2e253a203b2f3bf6da1fd6dc
+DIST wlc-0.0.7.tar.bz2 234305 SHA256 47e9b756d3fd621df913a6fbc9378c47aa8f9c3be7c2228a657a2411a7211979 SHA512 19775e965d5fc6501be4fa004955e4403859dfbcfaa99897977f4ad3a13493c08a70f7e5c77a1ab76e892c3fa855658a37082bd077287ead08240888b7fc17f0 WHIRLPOOL 57c746a5331686b112920353dff8797a6fbaaca4c6241573659a54649c6214b2224d5dd0fad202574a1358fc06b5d8dcc47c563d216ad0333347a283564cc85f
diff --git a/dev-libs/wlc/wlc-0.0.7.ebuild b/dev-libs/wlc/wlc-0.0.7.ebuild
new file mode 100644
index 000000000000..a48af99a5064
--- /dev/null
+++ b/dev-libs/wlc/wlc-0.0.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A helper library for Wayland compositors"
+HOMEPAGE="https://github.com/Cloudef/wlc"
+
+SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X static-libs systemd xwayland"
+
+RDEPEND="virtual/opengl
+ media-libs/mesa[wayland,gbm,gles2,egl]
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon
+ x11-misc/xkeyboard-config
+ dev-libs/libinput
+ dev-libs/wayland
+ X? ( x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/libXfixes )
+ xwayland? ( x11-base/xorg-server[wayland] )
+ systemd? ( sys-apps/systemd sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.7"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWLC_BUILD_EXAMPLES=OFF
+ -DWLC_BUILD_TESTS=OFF
+ -DWLC_BUILD_STATIC=$(usex static-libs)
+ -DWLC_X11_SUPPORT=$(usex X)
+ $(cmake-utils_use_find_package systemd Systemd)
+ $(cmake-utils_use_find_package systemd Dbus)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use X && !use xwayland; then
+ elog "xwayland use flag is required for X11 applications support"
+ fi
+ ewarn "This wlc version does not support displaying"
+ ewarn "Qt, EFL and Gtk+<3.22 applications natively (without Xwayland)."
+ ewarn "It is required for Gtk+ 3.22 applications though."
+}