summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-04-26 20:27:19 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-04-26 20:28:38 -0400
commite491bddcc0f3db45b179b4067b8dd325acaceeba (patch)
tree5259c94b4bf3ed788466593c0940818cbdb0ceea /dev-libs/xapian-bindings
parentapp-text/xapian-omega: version bump to 1.4.4 (diff)
downloadgentoo-e491bddcc0f3db45b179b4067b8dd325acaceeba.tar.gz
gentoo-e491bddcc0f3db45b179b4067b8dd325acaceeba.tar.bz2
gentoo-e491bddcc0f3db45b179b4067b8dd325acaceeba.zip
dev-libs/xapian-bindings: version bump to 1.4.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/xapian-bindings')
-rw-r--r--dev-libs/xapian-bindings/Manifest1
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.4.4.ebuild158
2 files changed, 159 insertions, 0 deletions
diff --git a/dev-libs/xapian-bindings/Manifest b/dev-libs/xapian-bindings/Manifest
index 976d358eb496..5c3b351a3197 100644
--- a/dev-libs/xapian-bindings/Manifest
+++ b/dev-libs/xapian-bindings/Manifest
@@ -1,3 +1,4 @@
DIST xapian-bindings-1.2.22.tar.xz 844040 SHA256 b15ca7984980a1d2aedd3378648ef5f3889cb39a047bac1522a8e5d04f0a8557 SHA512 0eec204ebb92f1230b9dbd080ad2b56ea5fa8e6170eb4354556e5790c7a7da7ba4c8475aaf86fb8f10f102a461d91590184271220626315f55c0631e73e122e0 WHIRLPOOL 05ac5b31d73f9de0c101da832ef289f6a505baa68216eba6fa0cf80df1709feef7e42c7b8f4cf9af35f775e8514c6d4b944c2acebffff10bc558a83305a637ce
DIST xapian-bindings-1.2.24.tar.xz 886148 SHA256 0c2a0df0a4616e2bd8e578d372c9bb4684780573abebbd1ac515502177229965 SHA512 aaedac02ec9fb192ef8b45b07bef5584bc60aff7068c2e3fa0008430ed8296a653780cad04176431d81fe014802df333a3090469dce63204923eead15e6bbaef WHIRLPOOL 996b960727a79dbe669ae8139863c3896c6efdbe781177098d00960982b86a43739433c69db32e62b6660dd4751736d859f5d950d26d6b635c310c35d75a8a0f
DIST xapian-bindings-1.4.3.tar.xz 1114408 SHA256 65b5455bf81e4f39fda49a6ad99353b05889d11d7c4c2cae001a0a1e0dac0d87 SHA512 a01ffd8d7051040983d2270f0631a3c3d99f8e9a6fa7d2d70d5be10774ccc1356d2b93d0d9ca8764388c8616ca6dba361d0def9ae262d1836cddd95f9188eb44 WHIRLPOOL 966a12bcbb7bd2fd9fa7d0f797313ca6f6a1a061fc174d927026b1afa2cd93c15909887590bba4b463d56b2cbb745219ed1652ae22cd61e7f7dd48ff16a11ff2
+DIST xapian-bindings-1.4.4.tar.xz 1117140 SHA256 3b323eac41c42750b7dacc9319b1477a7c1b552c95f590127643dee3b44d8a39 SHA512 006e771b3ea654130b4f76f1a1caee576fd5a3fa6317ca44f1e5483671e8c83073ecbde4f3fc7f84c75590eec53acb59701af4cf9bcd72355ed9d53924492b53 WHIRLPOOL 6932654e8fb4feea2de6db9f58273ab1fd253e0a90992377224c94a671979e102992052396fc319a5a3a8b3122d6a12d43a4bcd73e81e9dfc2b1a3b04838beae
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.4.4.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.4.4.ebuild
new file mode 100644
index 000000000000..52aa1bece6c9
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.4.4.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="threads(+)"
+
+USE_PHP="php5-6"
+
+PHP_EXT_NAME="xapian"
+PHP_EXT_INI="yes"
+PHP_EXT_OPTIONAL_USE="php"
+
+inherit distutils-r1 libtool java-pkg-opt-2 mono-env php-ext-source-r2 toolchain-funcs
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="java lua mono perl php python ruby tcl"
+REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )"
+
+COMMONDEPEND="dev-libs/xapian:0/30
+ lua? ( dev-lang/lua:= )
+ perl? ( dev-lang/perl:= )
+ python? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ ruby? ( dev-lang/ruby:= )
+ tcl? ( dev-lang/tcl:= )
+ mono? ( dev-lang/mono )"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6 )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.6 )"
+
+pkg_setup() {
+ use mono && mono-env_pkg_setup
+ use java && java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ use java && java-pkg-opt-2_src_prepare
+
+ # http://trac.xapian.org/ticket/702
+ export XAPIAN_CONFIG="/usr/bin/xapian-config"
+
+ # Accept ruby 2.0 - patch configure directly to avoid autoreconf
+ epatch "${FILESDIR}"/${PN}-1.3.6-allow-ruby-2.0.patch
+
+ if use python; then
+ python_copy_sources
+ fi
+}
+
+src_configure() {
+ local conf=(
+ --disable-documentation
+ --without-csharp
+ --without-python
+ --without-python3
+ )
+
+ if use java; then
+ export CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
+ conf+=( --with-java )
+ fi
+
+ if use perl; then
+ export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
+ export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
+ conf+=( --with-perl )
+ fi
+
+ if use lua; then
+ export LUA_LIB="$($(tc-getPKG_CONFIG) --variable=INSTALL_CMOD lua)"
+ conf+=( --with-lua )
+ fi
+
+ if use php; then
+ if has_version "=dev-lang/php-7*"; then
+ conf+=( --with-php7 )
+ else
+ conf+=( --with-php )
+ fi
+ fi
+
+ use ruby && conf+=( --with-ruby )
+ use tcl && conf+=( --with-tcl )
+ use mono && conf+=( --with-csharp )
+
+ econf ${conf[@]}
+
+ python_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-php
+ --without-ruby
+ --without-tcl
+ )
+ if python_is_python3; then
+ myconf+=( --with-python3 )
+ else
+ myconf+=( --with-python )
+ fi
+
+ # Avoid sandbox failures when compiling modules
+ addpredict "$(python_get_sitedir)"
+
+ econf "${myconf[@]}"
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ default
+ if use python; then
+ unset PYTHONDONTWRITEBYTECODE
+ python_foreach_impl run_in_build_dir emake
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use java; then
+ java-pkg_dojar java/built/xapian_jni.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso java/.libs/libxapian_jni.so
+ rm -rf "${D}var" || die "could not remove java cruft!"
+ fi
+
+ use php && php-ext-source-r2_createinifiles
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ fi
+
+ # For some USE combinations this directory is not created
+ if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}" || die
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README
+}