summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-10-18 18:25:05 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-10-18 19:05:06 -0400
commita738a157a2c471e1b70028d9417205491baa74b9 (patch)
treea978ec42dff09df7bd8b34360892b6a12488c0d8 /dev-libs/xapian/xapian-1.4.5.ebuild
parentdev-perl/Crypt-DES: EAPI6 + Test love (diff)
downloadgentoo-a738a157a2c471e1b70028d9417205491baa74b9.tar.gz
gentoo-a738a157a2c471e1b70028d9417205491baa74b9.tar.bz2
gentoo-a738a157a2c471e1b70028d9417205491baa74b9.zip
dev-libs/xapian: version bump to 1.4.5
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/xapian/xapian-1.4.5.ebuild')
-rw-r--r--dev-libs/xapian/xapian-1.4.5.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/xapian/xapian-1.4.5.ebuild b/dev-libs/xapian/xapian-1.4.5.ebuild
new file mode 100644
index 000000000000..923b057a6bef
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use glass || myconf="${myconf} --disable-backend-glass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}