summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-02-13 09:53:39 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-02-13 09:54:07 -0500
commit8139e67d1376a97855c01879cb44e4769d0e124e (patch)
tree7c8b941f365ae40859e27f19e21424b19c1e43f8 /dev-libs/xapian
parent[QA] Revert "dev-lisp/sbcl: Fix for bug #572478" (diff)
downloadgentoo-8139e67d1376a97855c01879cb44e4769d0e124e.tar.gz
gentoo-8139e67d1376a97855c01879cb44e4769d0e124e.tar.bz2
gentoo-8139e67d1376a97855c01879cb44e4769d0e124e.zip
dev-libs/xapian: rev bump 1.3.4, resolve bug #573466
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/xapian-1.3.4-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/xapian/xapian-1.3.4-r1.ebuild b/dev-libs/xapian/xapian-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..634112358c45
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.3.4-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/1.3.4" # ABI version of libxapian-1.3.so, prefixed with 1.3.
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use cpu_flags_x86_sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}" || die
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+src_test() {
+ emake check VALGRIND=
+}