summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-11 22:47:24 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-11 22:50:57 +0900
commit01f98a2ce07d3047b7bd2c7e8bc41af631af1317 (patch)
treef0374ba2029c929fe3477217c31e27261d03cff1 /dev-libs
parentapp-admin/hcloud: version bump to 1.18.0 (diff)
downloadgentoo-01f98a2ce07d3047b7bd2c7e8bc41af631af1317.tar.gz
gentoo-01f98a2ce07d3047b7bd2c7e8bc41af631af1317.tar.bz2
gentoo-01f98a2ce07d3047b7bd2c7e8bc41af631af1317.zip
dev-libs/input-pad: do not compress man pages
Closes: https://bugs.gentoo.org/734262 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/input-pad/files/input-pad-man.patch23
-rw-r--r--dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild7
2 files changed, 28 insertions, 2 deletions
diff --git a/dev-libs/input-pad/files/input-pad-man.patch b/dev-libs/input-pad/files/input-pad-man.patch
new file mode 100644
index 000000000000..f54580f776ed
--- /dev/null
+++ b/dev-libs/input-pad/files/input-pad-man.patch
@@ -0,0 +1,23 @@
+--- a/input-pad/Makefile.am
++++ b/input-pad/Makefile.am
+@@ -226,19 +226,15 @@
+ endif
+
+ man_one_in_files = input-pad.1.in
+-man_one_files = $(man_one_in_files:.1.in=.1)
+-man_one_DATA =$(man_one_files:.1=.1.gz)
++man_one_DATA = $(man_one_in_files:.1.in=.1)
+ man_onedir = $(mandir)/man1
+ %.1: %.1.in
+ $(AM_V_GEN) sed \
+ -e 's|@VERSION[@]|$(VERSION)|g' $< > $@.tmp && \
+ mv $@.tmp $@
+-%.1.gz: %.1
+- $(AM_V_GEN) gzip -c $< > $@.tmp && mv $@.tmp $@
+
+ CLEANFILES += \
+ $(BUILT_SOURCES) \
+- $(man_one_files) \
+ $(man_one_DATA) \
+ $(NULL)
+
diff --git a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
index f884a5d7fb2b..1ee24ba778e1 100644
--- a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
+++ b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit ltprune xdg-utils
+inherit autotools ltprune xdg-utils
MY_P="${P/_pre/.}"
MY_PV="${PV/_pre/.}"
@@ -33,8 +33,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
src_prepare() {
default
+ eautoreconf
xdg_environment_reset
}