summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-05-31 15:29:20 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2023-05-31 15:31:16 +0200
commit1a7fbac540cd29d4a88d0067750dd60c606d614b (patch)
treed4fd8718770987b289900f1b7371b60a708db4cb /dev-libs
parentsys-fs/lvm2: Stabilize 2.03.21 amd64, #907477 (diff)
downloadgentoo-1a7fbac540cd29d4a88d0067750dd60c606d614b.tar.gz
gentoo-1a7fbac540cd29d4a88d0067750dd60c606d614b.tar.bz2
gentoo-1a7fbac540cd29d4a88d0067750dd60c606d614b.zip
dev-libs/libax25: Install missing headers unconditionally for MUSL based systems
Closes: https://bugs.gentoo.org/907465 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libax25/files/libax25-0.0.12_rc5-musl.patch23
-rw-r--r--dev-libs/libax25/libax25-0.0.12_rc5.ebuild10
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-libs/libax25/files/libax25-0.0.12_rc5-musl.patch b/dev-libs/libax25/files/libax25-0.0.12_rc5-musl.patch
new file mode 100644
index 000000000000..2507d25ea83b
--- /dev/null
+++ b/dev-libs/libax25/files/libax25-0.0.12_rc5-musl.patch
@@ -0,0 +1,23 @@
+As MUSL libc does not provide netax25/ax25.h, netrom/netrom.h and
+netrose/rose.h instatll substitute files uncondiditionally. See bug #907465
+
+diff --git a/Makefile.am b/Makefile.am
+index 0ff5f37..517e084 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,15 +7,9 @@ libax25ioincludedir = $(includedir)
+ AM_CPPFLAGS = -DAX25_SYSCONFDIR=\""$(sysconfdir)/ax25/"\" \
+ -DAX25_LOCALSTATEDIR=\""$(localstatedir)/ax25/"\"
+
+-if !AX25_H
+ USE_LIBAX25_AX25_H = netax25/ax25.h
+-endif
+-if !NETROM_H
+ USE_LIBAX25_NETROM_H = netrom/netrom.h
+-endif
+-if !ROSE_H
+ USE_LIBAX25_ROSE_H = netrose/rose.h
+-endif
+
+ nobase_libax25include_HEADERS = \
+ netax25/axlib.h \
diff --git a/dev-libs/libax25/libax25-0.0.12_rc5.ebuild b/dev-libs/libax25/libax25-0.0.12_rc5.ebuild
index 7b1d1c34fbd9..3eea73794bff 100644
--- a/dev-libs/libax25/libax25-0.0.12_rc5.ebuild
+++ b/dev-libs/libax25/libax25-0.0.12_rc5.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_P=${PN}-$(ver_rs 3 '-')
+inherit autotools
+
DESCRIPTION="AX.25 library for hamradio applications"
HOMEPAGE="http://www.linux-ax25.org/"
SRC_URI="http://www.linux-ax25.org/pub/${PN}/${MY_P}.tar.xz"
@@ -16,6 +18,12 @@ IUSE="static-libs"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ use elibc_musl && eapply "${FILESDIR}/${P}-musl.patch"
+ eapply_user
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable static-libs static)
}