summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-18 20:29:49 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-18 22:18:53 +0200
commit28e20b497bfbc42c4ffc5abced934791f282e0c8 (patch)
tree5b738c081c5f45aa4df0f25f206b6274cfd03d91 /dev-libs
parentkernel-2.eclass: add global EAPI check (diff)
downloadgentoo-28e20b497bfbc42c4ffc5abced934791f282e0c8.tar.gz
gentoo-28e20b497bfbc42c4ffc5abced934791f282e0c8.tar.bz2
gentoo-28e20b497bfbc42c4ffc5abced934791f282e0c8.zip
dev-libs/xml-security-c: Allow for compiling with GCC 6
Gentoo-bug: 594234 * EAPI=6 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xml-security-c/files/xml-security-c-1.6.1-nss-compilation-fix.patch (renamed from dev-libs/xml-security-c/files/1.6.1-nss-compilation-fix.patch)0
-rw-r--r--dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch36
-rw-r--r--dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild17
3 files changed, 43 insertions, 10 deletions
diff --git a/dev-libs/xml-security-c/files/1.6.1-nss-compilation-fix.patch b/dev-libs/xml-security-c/files/xml-security-c-1.6.1-nss-compilation-fix.patch
index 1635d6b80339..1635d6b80339 100644
--- a/dev-libs/xml-security-c/files/1.6.1-nss-compilation-fix.patch
+++ b/dev-libs/xml-security-c/files/xml-security-c-1.6.1-nss-compilation-fix.patch
diff --git a/dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch b/dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch
new file mode 100644
index 000000000000..40783bf21b29
--- /dev/null
+++ b/dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch
@@ -0,0 +1,36 @@
+Fix building with C++14, which errors out due to bool -> T* conversions
+See also: https://bugs.gentoo.org/show_bug.cgi?id=594234
+
+--- a/xsec/enc/OpenSSL/OpenSSLCryptoSymmetricKey.hpp
++++ b/xsec/enc/OpenSSL/OpenSSLCryptoSymmetricKey.hpp
+@@ -151,7 +151,7 @@
+ SymmetricKeyMode mode = MODE_CBC,
+ const unsigned char * iv = NULL,
+ const unsigned char* tag = NULL,
+- unsigned int taglen = NULL);
++ unsigned int taglen = 0);
+
+ /**
+ * \brief Continue an decrypt operation using this key.
+--- a/xsec/enc/XSECCryptoSymmetricKey.hpp
++++ b/xsec/enc/XSECCryptoSymmetricKey.hpp
+@@ -185,7 +185,7 @@
+ SymmetricKeyMode mode = MODE_CBC,
+ const unsigned char* iv = NULL,
+ const unsigned char* tag = NULL,
+- unsigned int taglen = NULL) = 0;
++ unsigned int taglen = 0) = 0;
+
+ /**
+ * \brief Continue a decrypt operation using this key.
+--- a/xsec/tools/checksig/InteropResolver.cpp
++++ b/xsec/tools/checksig/InteropResolver.cpp
+@@ -645,7 +645,7 @@
+
+ }
+
+- return false;
++ return NULL;
+
+ }
+
diff --git a/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild b/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
index 7058fa18d4d4..ecd3748b1f61 100644
--- a/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
+++ b/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
@@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
-inherit eutils
+EAPI=6
DESCRIPTION="Apache C++ XML security libraries"
HOMEPAGE="http://santuario.apache.org/"
@@ -25,11 +23,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( CHANGELOG.txt NOTICE.txt )
-
-src_prepare() {
- epatch "${FILESDIR}/1.6.1-nss-compilation-fix.patch"
- epatch_user
-}
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.1-nss-compilation-fix.patch"
+ "${FILESDIR}/${PN}-1.7.3-fix-c++14.patch"
+)
src_configure() {
econf \
@@ -43,7 +40,7 @@ src_configure() {
src_install() {
default
if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins xsec/samples/*.cpp
+ docinto examples
+ dodoc xsec/samples/*.cpp
fi
}