summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-06 18:16:10 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-11 09:40:18 -0500
commit2c88ed9d5f36e6e05f61173d1ecf150e2a6a52dc (patch)
tree006490e2ccd1ba5c44cd2b24546d6f1015c8d8db /dev-libs
parentdev-libs/gobject-introspection: Version bump to 1.75.6 (diff)
downloadgentoo-2c88ed9d5f36e6e05f61173d1ecf150e2a6a52dc.tar.gz
gentoo-2c88ed9d5f36e6e05f61173d1ecf150e2a6a52dc.tar.bz2
gentoo-2c88ed9d5f36e6e05f61173d1ecf150e2a6a52dc.zip
dev-libs/gobject-introspection-common: Version bump to 1.75.6
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29967 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gobject-introspection-common/Manifest1
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.75.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/Manifest b/dev-libs/gobject-introspection-common/Manifest
index baaf52d4a791..883ececc6deb 100644
--- a/dev-libs/gobject-introspection-common/Manifest
+++ b/dev-libs/gobject-introspection-common/Manifest
@@ -1 +1,2 @@
DIST gobject-introspection-1.74.0.tar.xz 1044008 BLAKE2B 223bb9b8b452f03945f941086e47fb3b14f03f8353f4f903b21e3f494af728652a44de986752374057e90dd8111f21f5b0cd3e00bb0a8c3aa25c8261bb0b9247 SHA512 decff5dda0ec5ec0afda4d6bcd3bdadcbf34289002c0d9c0c77ecf8c5d3f15d196b24d8035041545031006acbdfe76af47c42da061c40e200c87f2c74cd301f0
+DIST gobject-introspection-1.75.6.tar.xz 1054100 BLAKE2B 3fb76550fc4f0ede1f0af93ef15d9923d25408ffc7d4f10fa4e10830ce1c7055760ec0fb11985f977eee9e81066e0712b4b6271398febd3e7592919db0335998 SHA512 6fb7b82c46eb79336ec654d34c94213bafd5ea6b293050698714c26afc929c73b6abbe75e09e992f0cccb7168f638a40219d6708e2758f620551a7b39306e0fb
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.75.6.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.75.6.ebuild
new file mode 100644
index 000000000000..bce7762306ba
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.75.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}