summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-02-02 05:28:00 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2016-02-02 05:28:00 +0300
commit3f45f91de0a6998760c3dbb3e827bacd95f0d46f (patch)
treef00552adaf7ccb8f77bc3f16b615112607338673 /dev-libs
parentnet-nds/nsscache: bump. (diff)
downloadgentoo-3f45f91de0a6998760c3dbb3e827bacd95f0d46f.tar.gz
gentoo-3f45f91de0a6998760c3dbb3e827bacd95f0d46f.tar.bz2
gentoo-3f45f91de0a6998760c3dbb3e827bacd95f0d46f.zip
dev-libs/uchardet: revbump to 0.0.5-r1 to fix return code on error
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/uchardet/files/uchardet-0.0.5-fix-return-code-on-error.patch19
-rw-r--r--dev-libs/uchardet/uchardet-0.0.5-r1.ebuild (renamed from dev-libs/uchardet/uchardet-0.0.5.ebuild)1
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/uchardet/files/uchardet-0.0.5-fix-return-code-on-error.patch b/dev-libs/uchardet/files/uchardet-0.0.5-fix-return-code-on-error.patch
new file mode 100644
index 000000000000..3b943afea15d
--- /dev/null
+++ b/dev-libs/uchardet/files/uchardet-0.0.5-fix-return-code-on-error.patch
@@ -0,0 +1,19 @@
+commit 248d6dbd351c22989090d318128cb38b11a89f98
+Author: Jehan <jehan@girinstud.io>
+Date: Thu Jan 21 18:16:42 2016 +0100
+
+ tools: exit with non-zero value on uchardet error.
+
+diff --git a/src/tools/uchardet.cpp b/src/tools/uchardet.cpp
+index 91912a0..bcfa234 100644
+--- a/src/tools/uchardet.cpp
++++ b/src/tools/uchardet.cpp
+@@ -60,7 +60,7 @@ void detect(FILE * fp)
+ if (retval != 0)
+ {
+ fprintf(stderr, "Handle data error.\n");
+- exit(0);
++ exit(1);
+ }
+ }
+ uchardet_data_end(handle);
diff --git a/dev-libs/uchardet/uchardet-0.0.5.ebuild b/dev-libs/uchardet/uchardet-0.0.5-r1.ebuild
index 1c0d57eb5393..0dd07643a822 100644
--- a/dev-libs/uchardet/uchardet-0.0.5.ebuild
+++ b/dev-libs/uchardet/uchardet-0.0.5-r1.ebuild
@@ -18,6 +18,7 @@ IUSE="static-libs test"
PATCHES=(
"${FILESDIR}/${P}-fix-ASCII-detection.patch"
"${FILESDIR}/${P}-use-proper-package-name.patch"
+ "${FILESDIR}/${P}-fix-return-code-on-error.patch"
)
src_prepare() {