summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-19 19:35:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-19 19:36:12 +0200
commit4b16ddb1fa76dcb64b41fd1fee4a66c140975c4b (patch)
tree983ad72d495738a6d6d0baab5260d460f9b6f3c9 /dev-libs
parentdev-libs/socketstream: EAPI=7 bump (diff)
downloadgentoo-4b16ddb1fa76dcb64b41fd1fee4a66c140975c4b.tar.gz
gentoo-4b16ddb1fa76dcb64b41fd1fee4a66c140975c4b.tar.bz2
gentoo-4b16ddb1fa76dcb64b41fd1fee4a66c140975c4b.zip
dev-libs/socketstream: Avoid unnecessary revbump
...for an ebuild that no one is feeling responsible for. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/socketstream/socketstream-0.7.0-r1.ebuild35
-rw-r--r--dev-libs/socketstream/socketstream-0.7.0-r2.ebuild37
2 files changed, 14 insertions, 58 deletions
diff --git a/dev-libs/socketstream/socketstream-0.7.0-r1.ebuild b/dev-libs/socketstream/socketstream-0.7.0-r1.ebuild
index 021c38edb975..741291a7e96b 100644
--- a/dev-libs/socketstream/socketstream-0.7.0-r1.ebuild
+++ b/dev-libs/socketstream/socketstream-0.7.0-r1.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
-
-inherit eutils
+EAPI=7
DESCRIPTION="C++ Streaming sockets library"
HOMEPAGE="http://socketstream.sourceforge.net/"
@@ -14,31 +12,26 @@ SLOT="0"
KEYWORDS="alpha amd64 ~hppa ~ppc ~sparc x86"
IUSE="doc"
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
+BDEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-missing_includes.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+)
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ default
# include/Makefile uses DIST_SUBDIRS and thus headers dont get installed
sed -i 's|^DIST_\(SUBDIRS =\)|\1|' include/Makefile.in || \
die "sed include/Makefile.in failed"
-
- epatch "${FILESDIR}"/${PV}-missing_includes.patch
- epatch "${FILESDIR}"/${P}-gcc47.patch
}
src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-
- if use doc ; then
- emake doxygen || die "failed to build docs"
- fi
+ default
+ use doc && emake doxygen
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README* HACKING TODO
- use doc && dohtml -r docs/html/*
+ use doc && local HTML_DOCS=( docs/html/. )
+ default
}
diff --git a/dev-libs/socketstream/socketstream-0.7.0-r2.ebuild b/dev-libs/socketstream/socketstream-0.7.0-r2.ebuild
deleted file mode 100644
index 1e749b199355..000000000000
--- a/dev-libs/socketstream/socketstream-0.7.0-r2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="C++ Streaming sockets library"
-HOMEPAGE="http://socketstream.sourceforge.net/"
-SRC_URI="mirror://sourceforge/socketstream/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="doc"
-
-BDEPEND="doc? ( app-doc/doxygen )"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-missing_includes.patch
- "${FILESDIR}"/${P}-gcc47.patch
-)
-
-src_prepare() {
- default
- # include/Makefile uses DIST_SUBDIRS and thus headers dont get installed
- sed -i 's|^DIST_\(SUBDIRS =\)|\1|' include/Makefile.in || \
- die "sed include/Makefile.in failed"
-}
-
-src_compile() {
- default
- use doc && emake doxygen
-}
-
-src_install() {
- use doc && local HTML_DOCS=( docs/html/. )
- default
-}