summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-23 15:19:18 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-23 15:19:23 +0100
commit56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b (patch)
tree5fe72abc880ea05e9261cdf41b631deebb1181d5 /dev-libs
parentnet-misc/networkmanager: security bump to 1.14.6 (diff)
downloadgentoo-56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b.tar.gz
gentoo-56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b.tar.bz2
gentoo-56ed2d8c87eb9117cfd4ddb2c1e7be2dc5a5ea6b.zip
Revert "dev-libs/xapian: remove older versions"
This partially reverts commit c9ef851344067d8b1dd2efa827faefa74f25b6a4. =dev-libs/xapian-1.2.24 is still required for stable dev-perl/Search-Xapian-1.2.25.0. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.2.24.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index ca5761c012f5..eadc2d393c42 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -1,3 +1,4 @@
+DIST xapian-core-1.2.24.tar.xz 3210192 BLAKE2B 062f0c15ce87fb64b0eec5e5e54b76c443d0581feab44791bce6925f0f77385b423218dc7006d7e095cc9764fffc73a74a067923c44f51816d94b731d001f903 SHA512 1f8ae5848f94b5f0bee03024f12ae8c336b6d85e58f7b36e885fe604f9fb962c0525e1f44e6cfcd183e811226c61b23f0f2fcc35c7d2e63544b19347a0f96c80
DIST xapian-core-1.2.25.tar.xz 3253292 BLAKE2B a130e26188c949d0433d017e8d13e7ecf6241a232d00125699ba8ed63eab9cb1651e02182fcc152f960f4e122709958632779daaaf5760fe50953a3b5b07a243 SHA512 a15b5d9b5770337519f671732f53f0642b31f08206824500d589ba309c9e91a05a30353d66ebf70a4c1cb1824b44e1c7b7630e799de3b15d645cf951a6017bfe
DIST xapian-core-1.4.10.tar.xz 2973780 BLAKE2B 6ef86a4c02e6721f434e33ea27a37ddac9cee62f0c9eed8c6334cadb62dd544be66405dd359dd944cf1ab12742c10e786b7300c4987e33ce33da9d9df4e428d4 SHA512 fa716d6f8c04edb297d99dad4d7835f7874837ab3c39d7017e43708cde6992c596e579418be17b79772e002bd23b94169812523a1abd9519b1dd3df474f027d9
DIST xapian-core-1.4.5.tar.xz 2810612 BLAKE2B 7784e69e3ca064751d829173949fcde65661c2c2070fdc8392cf2b6d40874a3e5b1265e61f25dd39b33e179b3fe3842b67f33a55523c3a18e9b65528e6a23a1e SHA512 cff97a856a406583ca81164ddb704a0eeae7d8d6f94ce3b3f53d5208d657423e87dd06bdc7acb5e5904765bce1cefbc98365cde315c1d46f7b18cfba7b022ae6
diff --git a/dev-libs/xapian/xapian-1.2.24.ebuild b/dev-libs/xapian/xapian-1.2.24.ebuild
new file mode 100644
index 000000000000..ebe151278a9c
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.24.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/1.2.22" # ABI version of libxapian.so, prefixed with 1.2.
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ einfo
+ if use cpu_flags_x86_sse2; then
+ einfo "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ einfo "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ einfo "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ einfo
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-flint --enable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${ED}usr/share/doc/xapian-core" "${ED}usr/share/doc/${PF}" || die
+ use doc || rm -rf "${ED}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+src_test() {
+ emake check VALGRIND=
+}