summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-22 14:56:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-22 16:32:18 +0200
commit9f7be0f3d737f6a5dacf7ec3f75b9197e401ac6f (patch)
treec83d5c4e333333b01798876e9962bfc86850f4e2 /dev-libs
parentapp-cdr/cdrdao: Bump to version 1.2.4 (diff)
downloadgentoo-9f7be0f3d737f6a5dacf7ec3f75b9197e401ac6f.tar.gz
gentoo-9f7be0f3d737f6a5dacf7ec3f75b9197e401ac6f.tar.bz2
gentoo-9f7be0f3d737f6a5dacf7ec3f75b9197e401ac6f.zip
dev-libs/libbsd: Bump to version 0.9.0
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.9.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index 7a1373229e8f..3cbe9f5f43c8 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1,2 +1,3 @@
DIST libbsd-0.8.6.tar.xz 371112 BLAKE2B adab6c17267e0cff128351efccf5c1225b7dd85dc61dd8168bf212ba5aff8d726fa5be687c041821af9a427ddad9dfcd3630cac9134b9e81c86ab2599e43aef9 SHA512 ece01ced324f840c2cee6321c7dcf97ff123d55ea9f203c1ce35e1b46643dc7b34ef6dc6c8d128252b36848624850b40823411cc96b99a66a401eb1e9d8cea6b
DIST libbsd-0.8.7.tar.xz 371772 BLAKE2B aa4aa1c19872edf9e7e6ed270275199366345531a48ee28c25e209f17c5403a22269b91ab1c806cb1b54ba33a8464f4b035fe7ee2bc5dddd0a4fda09c540b058 SHA512 605a14eb5d33c0e45c3bd29e585ebc15832e2ed1efa9356291a0562622168da96db1a20766e9dae8910ea0c1516429f43905edc8d4f2a40a5a341a689d08fcc3
+DIST libbsd-0.9.0.tar.xz 385792 BLAKE2B c9628bea4b97ea2c8b042b50a1807da216f265ade30043811199527d28df55deb891fd521fb09e5aa9a9373222426a1b365cf710cd5988ac8e154d1c5d5d85df SHA512 76adcb03f7ef2299178aa489ab6d298a2e2b0a38ea4341ea18f8d1a24fc46a6f9612d2138481d2c7e0ad248490dc0a2d018eb86e3e13a11ceb2383a3d4207642
diff --git a/dev-libs/libbsd/libbsd-0.9.0.ebuild b/dev-libs/libbsd/libbsd-0.9.0.ebuild
new file mode 100644
index 000000000000..bde7f808bf8b
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND=">=sys-kernel/linux-headers-3.17"
+RDEPEND=""
+
+pkg_setup() {
+ local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ find "${ED}" -name "*.la" -delete || die
+}