summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-01-26 21:50:54 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-01-26 21:51:22 +0100
commit9fdac5a0cb2850e12153b8f160e7e568b716b996 (patch)
treeafbc96ba3b78b7bcddd6d10008692c45d61fe31b /dev-libs
parentprofiles: Mask app-cdr/webcdwriter (diff)
downloadgentoo-9fdac5a0cb2850e12153b8f160e7e568b716b996.tar.gz
gentoo-9fdac5a0cb2850e12153b8f160e7e568b716b996.tar.bz2
gentoo-9fdac5a0cb2850e12153b8f160e7e568b716b996.zip
dev-libs/libinput: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.1.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index df0196e279a6..0f7d21ebe853 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -3,3 +3,4 @@ DIST libinput-1.0.1.tar.xz 800244 SHA256 482fb35119b457ba65a8bebaa47e4f6b4dbd77e
DIST libinput-1.1.0.tar.xz 802348 SHA256 673186ea2a0d2b695afaa9758834f9217b175774d9ae222e1b43ff63c663f582 SHA512 7f014eabed120c00fcd2d8748aed44a8ca31fd30bdda8b289ca63f7d1bebb9c49f1d508707fb0c4a5c7c4a37b58548efdff0e9b7761475f18e1cf787a80520e6 WHIRLPOOL 028518c20cfc6daa442dd92d04183a6575b95b1f4792a646ce42c09a7bc75e5bb469ca88b8cad89919c0814e00aa65178cc49c9dca6e9aad4ce997a94f9ba645
DIST libinput-1.1.3.tar.xz 815840 SHA256 b95af39391e2b91957af0addce691a4070b28aff69cd2348823bf6ce8169995e SHA512 ee51b6d005bacca57c4cad5a8b70097990299bf934cb460016176630009cea872e5413e053b09b456d35e085268a9a96ceb667ef0f4cd3b874e89cda2bb1c344 WHIRLPOOL 2934b26ef372f337873eefc5fd0c3464e8d380fc263a6cd0fda759fa5d1efe974dd3a83e076aec0ee2e85259784452c7294b163f8ca657af9c2c803c69540867
DIST libinput-1.1.4.tar.xz 819536 SHA256 302cb76209b9c57a5a318e178f9bc446eede8ea79386103b5291cbfaa5fab5b6 SHA512 54c1ca1cbb747d62950f5f5bf6a906cdb6b0e79305ba9d7e8408828691eb523be517bb88e739c6ab5465ec95b69c81f096fe8ad4b6bbbd010d431e72d79d0763 WHIRLPOOL 82b9831bce546d4d1329fbf51f64bfea8a1d23bee11cf1664212ba7949e18bff6ae471e2e248f8ec16dc93d8514024a5576fb2a298edea433899c2a69189d6b8
+DIST libinput-1.1.5.tar.xz 806960 SHA256 5e08c45dbb8bf32490cc6cd626da098564d646d161a07cba2e3adbd9745c0622 SHA512 031663c46b556048224aab018eb8ea76e34aace77508e52e6ef382a452585fafd4c91b427c0892aab3c624c0cfedc15c388922ae7166248e5da65575ff900c31 WHIRLPOOL 760cc1cf0c6657efbdadadd2f50e188d86465e1aa3f287275323d6fad9156b684de0d3b6dbf6e3fd5213018770726087ee282833f25ba5ef67918c0284b885a1
diff --git a/dev-libs/libinput/libinput-1.1.5.ebuild b/dev-libs/libinput/libinput-1.1.5.ebuild
new file mode 100644
index 000000000000..c1d8674d12ab
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.1.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}