summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-02-19 16:44:59 +0100
committerDavid Seifert <soap@gentoo.org>2018-02-19 16:47:24 +0100
commita3dbcfbf921c45270e79d212de867661d419718a (patch)
tree284b1f44390dd0023015b34e5103da13cd513be8 /dev-libs
parentsys-devel/make: Fixed typo in a comment. (diff)
downloadgentoo-a3dbcfbf921c45270e79d212de867661d419718a.tar.gz
gentoo-a3dbcfbf921c45270e79d212de867661d419718a.tar.bz2
gentoo-a3dbcfbf921c45270e79d212de867661d419718a.zip
dev-libs/xmlwrapp: Version bump to 0.8.1
Closes: https://bugs.gentoo.org/619804 Closes: https://bugs.gentoo.org/619354 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xmlwrapp/Manifest1
-rw-r--r--dev-libs/xmlwrapp/xmlwrapp-0.8.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/xmlwrapp/Manifest b/dev-libs/xmlwrapp/Manifest
index fe54604d9373..8927c17497af 100644
--- a/dev-libs/xmlwrapp/Manifest
+++ b/dev-libs/xmlwrapp/Manifest
@@ -1 +1,2 @@
DIST xmlwrapp-0.7.1.tar.gz 1453771 BLAKE2B 33889ef53e8c154b10a1e8d3f0ff4ceaa6de9c68f61230028aeea86bb41be2eba9e464ad6717f57ee572297d218d1077108bb3fea5b54ce1d92a2620cadf8d70 SHA512 73aaa9821f861edaab8e83d97414c9525ae7f6281a4812d8df6239e10ec76dd941cc0a8ed4769469084f694642c2f0c978f6c7477c63f99735a8cc9d98d7b9a0
+DIST xmlwrapp-0.8.1.tar.gz 1470707 BLAKE2B 213923b5e74f79a6d966ded4b9c9dfb5e6906bc44dd5d79099ee146f852233675d59f33908ee4a2c844332e1b3f7b064770ddcdcd2cea0745bdac6e1329ec3de SHA512 f6415c7cbbe209f7ee148eff4ee5aca4f210b2ab420dbc89b2cdbca1f270097c362ecb456b0cc72cbebc8688fbc66ee3a94c1019d80e7211a9ebe44ddbd535eb
diff --git a/dev-libs/xmlwrapp/xmlwrapp-0.8.1.ebuild b/dev-libs/xmlwrapp/xmlwrapp-0.8.1.ebuild
new file mode 100644
index 000000000000..ed8327256b08
--- /dev/null
+++ b/dev-libs/xmlwrapp/xmlwrapp-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="modern style C++ library that provides a simple and easy interface to libxml2"
+HOMEPAGE="http://vslavik.github.io/xmlwrapp/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/6.4" # subslot = SONAME(libxmlwrapp.so) + SONAME(libxsltwrapp.so)
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/boost:=[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:=[${MULTILIB_USEDEP}]
+ dev-libs/libxslt:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/boost-m4"
+
+src_prepare() {
+ default
+
+ # Unbundle boost.m4, rely on
+ # sys-devel/boost-m4 instead
+ rm admin/boost.m4 || die
+
+ sed -i -e '/XMLWRAPP_VISIBILITY/d' configure.ac || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # bug 619804
+ local -x CXXFLAGS="${CXXFLAGS}"
+ append-cxxflags -std=c++14
+
+ ECONF_SOURCE=${S} econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package installs .pc files
+ find "${D}" -name '*.la' -delete || die
+}