summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-02-12 18:56:16 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-02-12 18:56:16 -0500
commita4c3992d87691624583cc7fb96d1d6cbba309d8e (patch)
tree3b109799554d784dc120f0d8e6fb8dad2cf83a6f /dev-libs
parentdev-lua/lua-cjson: switch to fork, bump to 2.1.0.6 (diff)
downloadgentoo-a4c3992d87691624583cc7fb96d1d6cbba309d8e.tar.gz
gentoo-a4c3992d87691624583cc7fb96d1d6cbba309d8e.tar.bz2
gentoo-a4c3992d87691624583cc7fb96d1d6cbba309d8e.zip
dev-libs/libbsd: fix bug #677746
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libbsd/files/libbsd-0.9.1-missing-header.patch43
-rw-r--r--dev-libs/libbsd/libbsd-0.9.1.ebuild6
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/libbsd/files/libbsd-0.9.1-missing-header.patch b/dev-libs/libbsd/files/libbsd-0.9.1-missing-header.patch
new file mode 100644
index 000000000000..7ca2b881a388
--- /dev/null
+++ b/dev-libs/libbsd/files/libbsd-0.9.1-missing-header.patch
@@ -0,0 +1,43 @@
+From 13c32916b4baab58d93940d57fea9ff0777f1931 Mon Sep 17 00:00:00 2001
+From: Baruch Siach <baruch@tkos.co.il>
+Date: Tue, 5 Jun 2018 19:21:46 +0300
+Subject: flopen: Add missing <fcntl.h> include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Commit 993828d84ee (Add flopenat() function from FreeBSD) dropped the
+fcntl.h header. This breaks the build with musl libc:
+
+flopen.c: In function ‘vflopenat’:
+flopen.c:60:14: error: ‘O_CREAT’ undeclared (first use in this function)
+ if (flags & O_CREAT) {
+ ^~~~~~~
+
+Restore the fcntl.h header include to fix the build.
+
+Fixes: commit 993828d84eed0468c6c15b2818e534e6b134b8e4
+Submitted-also-by: parazyd <parazyd@dyne.org>
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+Signed-off-by: Guillem Jover <guillem@hadrons.org>
+---
+ src/flopen.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+(limited to 'src/flopen.c')
+
+diff --git a/src/flopen.c b/src/flopen.c
+index b9972c9..ff20d07 100644
+--- a/src/flopen.c
++++ b/src/flopen.c
+@@ -32,6 +32,7 @@
+ #include <sys/stat.h>
+
+ #include <errno.h>
++#include <fcntl.h>
+ #include <stdarg.h>
+ #include <unistd.h>
+
+--
+cgit v1.1
+
diff --git a/dev-libs/libbsd/libbsd-0.9.1.ebuild b/dev-libs/libbsd/libbsd-0.9.1.ebuild
index a3299a2bcae9..fbc48c4614da 100644
--- a/dev-libs/libbsd/libbsd-0.9.1.ebuild
+++ b/dev-libs/libbsd/libbsd-0.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,6 +16,10 @@ IUSE="static-libs"
DEPEND=">=sys-kernel/linux-headers-3.17"
RDEPEND=""
+PATCHES=(
+ "${FILESDIR}/${P}-missing-header.patch"
+)
+
pkg_setup() {
local f="${EROOT}/usr/$(get_libdir)/${PN}.a"
local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."