summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-12-09 15:25:20 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-12-09 15:26:35 +0100
commita5b87d930d6669beab43f3a6d286801f3f9bd3fc (patch)
tree30f62bdfae43ea860a86ebd91a4a43aa46fc511c /dev-libs
parentwww-apps/piwigo: bump to 2.8.3 (diff)
downloadgentoo-a5b87d930d6669beab43f3a6d286801f3f9bd3fc.tar.gz
gentoo-a5b87d930d6669beab43f3a6d286801f3f9bd3fc.tar.bz2
gentoo-a5b87d930d6669beab43f3a6d286801f3f9bd3fc.zip
dev-libs/libinput: Version bump to 1.5.3
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.5.3.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index c83f0966a885..9247fee63bb9 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -4,3 +4,4 @@ DIST libinput-1.3.3.tar.xz 881992 SHA256 30c8edfe47654a38c235ac6b0541d79fd593d01
DIST libinput-1.4.2.tar.xz 900776 SHA256 8c38826a785594811bef6a9daadbfa2e172e3f070f8863393d6fb7ca4c68e451 SHA512 ecd1ddc737b8207d9e494f809340e2c0ac2927db80cf4c325ba12fb84387138d0128df7e841c87feafe425d6382f87f123f28531f7045fbcdd1176559895b79b WHIRLPOOL 99f18e00e2a4a284b7995f677053501989b526e16f41e508023638a1c0e660940d0cb991f399480a30a49073063aab1651e52bdea7861266300d9db885806ac4
DIST libinput-1.5.1.tar.xz 926872 SHA256 d4f63933b0967bd691735af5e3919e2d29c2121d4e05867cc4e10ff3ae8e2dd8 SHA512 13cf61ec3cc67687ee4cbe6fffd1cec722d4c0b328f5fddc9e0c655af1cdc5030b3cebeb32374917df2bd14eeee74e2be9ea97af52d006e08f447932bf525e9a WHIRLPOOL eceebd33bb530f5c673deca743980d2b5c39c24a7eff49c1bfa4f15f23b104d5173fd62a433f1d1881aa4362b4203fa8944a738350124720034e692b2e9af5ea
DIST libinput-1.5.2.tar.xz 926048 SHA256 ba26e2bc64ed551eaef193178ed06b07b97a09ac6f4e442f5f15bbc3f3174682 SHA512 a3552f36fc91b523caceb128d048a0a7161335aef78554f202011fcc9acfb5f772d2124a4441f0f542f1b8051b8a2ecb7b00fad5456d8c06b213b96b9ebc91de WHIRLPOOL 025cd1b3261a977b2a579e03766939a443b6fa26b486e9fa16e445b39acf5d31b1f74260670b74718e5d11648c459b42b546e2311d5cac8a713a8a5b0e893791
+DIST libinput-1.5.3.tar.xz 928852 SHA256 91206c523b4e7aeecf296d0b94276c61bea90b9260d198c8ee3a91eced10a6e3 SHA512 4d5ca9189275d6f2ed40ff85903bf10ae3b15ceaea43a3565384b6495a9b1764fed1f95c667dfa9e96170b3709a9c8dc1d1bad88cb82d0de69045b7c5f0bc7e6 WHIRLPOOL 548f08f755abf0c01c42a4e21abdcd4068b16dd57d37035922c390f17a9cfba52f56aab1dfb693ed13666a9d94cffef38cb4c7c7d030e9898c1bfdb3fb54d501
diff --git a/dev-libs/libinput/libinput-1.5.3.ebuild b/dev-libs/libinput/libinput-1.5.3.ebuild
new file mode 100644
index 000000000000..8ec94bd29692
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.5.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.12 )
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_prepare() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable input_devices_wacom libwacom) \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}