summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 08:42:27 -0500
committerSebastian Pipping <sping@gentoo.org>2018-04-21 22:56:09 +0200
commitab15b7fa1819dfce3e4b55138922f25a5b8d3eee (patch)
treeee4e2e2f9cd35b2baa649e03ccb2ad4734fc0d2d /dev-libs
parentapp-shells/bash-4.4_p12: arm64 stable (bug #643124) (diff)
downloadgentoo-ab15b7fa1819dfce3e4b55138922f25a5b8d3eee.tar.gz
gentoo-ab15b7fa1819dfce3e4b55138922f25a5b8d3eee.tar.bz2
gentoo-ab15b7fa1819dfce3e4b55138922f25a5b8d3eee.zip
dev-libs/expat: epatch->PATCHES=()
Also reformatted the patches to be -p1 applicable, and switched eapply_user to default. Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/expat/expat-2.2.1.ebuild11
-rw-r--r--dev-libs/expat/expat-2.2.4.ebuild2
-rw-r--r--dev-libs/expat/expat-2.2.5.ebuild2
-rw-r--r--dev-libs/expat/files/expat-2.2.1-gentoo-dash.patch4
-rw-r--r--dev-libs/expat/files/expat-2.2.1-getrandom-detection.patch4
-rw-r--r--dev-libs/expat/files/expat-2.2.1-posix-shell.patch4
6 files changed, 15 insertions, 12 deletions
diff --git a/dev-libs/expat/expat-2.2.1.ebuild b/dev-libs/expat/expat-2.2.1.ebuild
index 9a4ba03a1ee9..ac06d60513e4 100644
--- a/dev-libs/expat/expat-2.2.1.ebuild
+++ b/dev-libs/expat/expat-2.2.1.ebuild
@@ -16,11 +16,14 @@ RDEPEND=""
DOCS=( AUTHORS Changes README )
+PATCHES=(
+ "${FILESDIR}"/${P}-getrandom-detection.patch
+ "${FILESDIR}"/${P}-posix-shell.patch
+ "${FILESDIR}"/${P}-gentoo-dash.patch # bug 622360
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-getrandom-detection.patch
- epatch "${FILESDIR}"/${P}-posix-shell.patch
- epatch "${FILESDIR}"/${P}-gentoo-dash.patch # bug 622360
- eapply_user
+ default
eautoreconf
}
diff --git a/dev-libs/expat/expat-2.2.4.ebuild b/dev-libs/expat/expat-2.2.4.ebuild
index 5ff41c1f875f..fc3869969b43 100644
--- a/dev-libs/expat/expat-2.2.4.ebuild
+++ b/dev-libs/expat/expat-2.2.4.ebuild
@@ -18,7 +18,7 @@ RDEPEND=""
DOCS=( README.md )
src_prepare() {
- eapply_user
+ default
# fix interpreter to be a recent/good shell
sed -i -e "1s:/bin/sh:${BASH}:" conftools/get-version.sh || die
diff --git a/dev-libs/expat/expat-2.2.5.ebuild b/dev-libs/expat/expat-2.2.5.ebuild
index e4888fba94b3..62fe398a4281 100644
--- a/dev-libs/expat/expat-2.2.5.ebuild
+++ b/dev-libs/expat/expat-2.2.5.ebuild
@@ -18,7 +18,7 @@ RDEPEND=""
DOCS=( README.md )
src_prepare() {
- eapply_user
+ default
# fix interpreter to be a recent/good shell
sed -i -e "1s:/bin/sh:${BASH}:" conftools/get-version.sh || die
diff --git a/dev-libs/expat/files/expat-2.2.1-gentoo-dash.patch b/dev-libs/expat/files/expat-2.2.1-gentoo-dash.patch
index a0eb60ce6cc0..9bf9bfe44929 100644
--- a/dev-libs/expat/files/expat-2.2.1-gentoo-dash.patch
+++ b/dev-libs/expat/files/expat-2.2.1-gentoo-dash.patch
@@ -10,8 +10,8 @@ Subject: [PATCH] conftools/get-version.sh: Use printf rather than try to infer
diff --git a/expat/conftools/get-version.sh b/expat/conftools/get-version.sh
index a70e0fb..91e5c64 100755
---- a/expat/conftools/get-version.sh
-+++ b/expat/conftools/get-version.sh
+--- a/conftools/get-version.sh
++++ b/conftools/get-version.sh
@@ -32,15 +32,4 @@ MAJOR_VERSION="`sed -n -e '/MAJOR_VERSION/s/[^0-9]*//gp' $hdr`"
MINOR_VERSION="`sed -n -e '/MINOR_VERSION/s/[^0-9]*//gp' $hdr`"
MICRO_VERSION="`sed -n -e '/MICRO_VERSION/s/[^0-9]*//gp' $hdr`"
diff --git a/dev-libs/expat/files/expat-2.2.1-getrandom-detection.patch b/dev-libs/expat/files/expat-2.2.1-getrandom-detection.patch
index eba004843db6..6ceb7d9993fc 100644
--- a/dev-libs/expat/files/expat-2.2.1-getrandom-detection.patch
+++ b/dev-libs/expat/files/expat-2.2.1-getrandom-detection.patch
@@ -11,8 +11,8 @@ There is no such thing but we need to link (not just compile) to realize.
diff --git a/expat/configure.ac b/expat/configure.ac
index 1357c9a..444c002 100644
---- a/expat/configure.ac
-+++ b/expat/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -130,7 +130,7 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([
diff --git a/dev-libs/expat/files/expat-2.2.1-posix-shell.patch b/dev-libs/expat/files/expat-2.2.1-posix-shell.patch
index 3f34d0d9853b..ab680451d8e0 100644
--- a/dev-libs/expat/files/expat-2.2.1-posix-shell.patch
+++ b/dev-libs/expat/files/expat-2.2.1-posix-shell.patch
@@ -11,8 +11,8 @@ It doesn't matter in bash, but some other sh don't like it, so it's a portabilit
diff --git a/expat/configure.ac b/expat/configure.ac
index e48c32e..1357c9a 100644
---- a/expat/configure.ac
-+++ b/expat/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -220,8 +220,8 @@ AS_HELP_STRING([--disable-xml-context],
[Do not retain context around the current parse point]),
[enable_xml_context=${enableval}])