summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2019-03-22 14:09:01 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2019-03-22 14:24:00 +0300
commitb65c3d9897a06a4d70a9f4b58f2ec506374f0f86 (patch)
treecccbf83574d2672ba152c62dba282c0b9429c9be /dev-libs
parentapp-i18n/zhcon: Fixed build with sys-libs/ncurses[tinfo] (diff)
downloadgentoo-b65c3d9897a06a4d70a9f4b58f2ec506374f0f86.tar.gz
gentoo-b65c3d9897a06a4d70a9f4b58f2ec506374f0f86.tar.bz2
gentoo-b65c3d9897a06a4d70a9f4b58f2ec506374f0f86.zip
dev-libs/openobex: qa fixes
1. Fix QA for unused cmake variable with USE="-usb". 2. Update to EAPI 7. Closes: https://bugs.gentoo.org/677898 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openobex/openobex-1.7.2-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/openobex/openobex-1.7.2-r2.ebuild b/dev-libs/openobex/openobex-1.7.2-r2.ebuild
new file mode 100644
index 000000000000..ab1632e42d34
--- /dev/null
+++ b/dev-libs/openobex/openobex-1.7.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils udev
+
+DESCRIPTION="Implementation of the OBEX protocol used for transferring data to mobile devices"
+HOMEPAGE="https://sourceforge.net/projects/openobex/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-Source.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bluetooth doc irda usb"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+DEPEND="
+ bluetooth? ( net-wireless/bluez:= )
+ usb? ( virtual/libusb:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-Source"
+
+PATCHES=( "${FILESDIR}/${P}-version.h.patch" )
+DOCS=( AUTHORS ChangeLog README UPGRADING.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DOPENOBEX_BLUETOOTH=$(usex bluetooth)
+ -DOPENOBEX_IRDA=$(usex irda)
+ -DOPENOBEX_USB=$(usex usb)
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ )
+ use usb && mycmakeargs+=( -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)/rules.d" )
+
+ cmake-utils_src_configure
+}