summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-20 23:03:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-23 20:52:24 +0100
commitbc6e277bad31948b11a7041e8479d4514a7a7060 (patch)
tree9d77d3826bc3eab75df1c5e18a5d6192645e78bc /dev-libs
parentdev-libs/quazip: Move version 1.1 from SLOT=1 to SLOT=0/1 (diff)
downloadgentoo-bc6e277bad31948b11a7041e8479d4514a7a7060.tar.gz
gentoo-bc6e277bad31948b11a7041e8479d4514a7a7060.tar.bz2
gentoo-bc6e277bad31948b11a7041e8479d4514a7a7060.zip
dev-libs/quazip: Drop 1.1 (r0)
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/quazip/files/quazip-1.1-conditional-tests.patch40
-rw-r--r--dev-libs/quazip/quazip-1.1.ebuild52
2 files changed, 0 insertions, 92 deletions
diff --git a/dev-libs/quazip/files/quazip-1.1-conditional-tests.patch b/dev-libs/quazip/files/quazip-1.1-conditional-tests.patch
deleted file mode 100644
index 68520a4b3b9d..000000000000
--- a/dev-libs/quazip/files/quazip-1.1-conditional-tests.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 14230a6..22c1421 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -26,34 +26,25 @@ set(QUAZIP_LIB_FILE_NAME quazip${QuaZip_VERSION_MAJOR}-qt${QUAZIP_QT_MAJOR_VERSI
- set(QUAZIP_LIB_TARGET_NAME QuaZip)
- set(QUAZIP_DIR_NAME QuaZip-Qt${QUAZIP_QT_MAJOR_VERSION}-${QUAZIP_LIB_VERSION})
- set(QUAZIP_PACKAGE_NAME QuaZip-Qt${QUAZIP_QT_MAJOR_VERSION})
--set(QUAZIP_ENABLE_TESTS OFF)
-+option(QUAZIP_ENABLE_TESTS "" OFF)
- if(QUAZIP_QT_MAJOR_VERSION EQUAL 6)
- find_package(Qt6 REQUIRED COMPONENTS Core Core5Compat
- OPTIONAL_COMPONENTS Network Test)
- set(QUAZIP_LIB_QT_LIBRARIES Qt6::Core Qt6::Core5Compat)
- set(QUAZIP_TEST_QT_LIBRARIES Qt6::Core Qt6::Core5Compat Qt6::Network Qt6::Test)
- set(QUAZIP_PKGCONFIG_REQUIRES Qt6Core)
-- if (Qt6Network_FOUND AND Qt6Test_FOUND)
-- set(QUAZIP_ENABLE_TESTS ON)
-- endif()
- elseif(QUAZIP_QT_MAJOR_VERSION EQUAL 5)
- find_package(Qt5 REQUIRED COMPONENTS Core
- OPTIONAL_COMPONENTS Network Test)
- set(QUAZIP_LIB_QT_LIBRARIES Qt5::Core)
- set(QUAZIP_TEST_QT_LIBRARIES Qt5::Core Qt5::Network Qt5::Test)
- set(QUAZIP_PKGCONFIG_REQUIRES Qt5Core)
-- if (Qt5Network_FOUND AND Qt5Test_FOUND)
-- set(QUAZIP_ENABLE_TESTS ON)
-- endif()
- elseif(QUAZIP_QT_MAJOR_VERSION EQUAL 4)
- find_package(Qt4 4.5.0 REQUIRED COMPONENTS QtCore
- OPTIONAL_COMPONENTS QtNetwork QtTest)
- set(QUAZIP_LIB_QT_LIBRARIES Qt4::QtCore)
- set(QUAZIP_TEST_QT_LIBRARIES Qt4::QtCore Qt4::QtNetwork Qt4::QtTest)
- set(QUAZIP_PKGCONFIG_REQUIRES QtCore)
-- if (QT_QTNETWORK_FOUND AND QT_QTTEST_FOUND)
-- set(QUAZIP_ENABLE_TESTS ON)
-- endif()
- else()
- message(FATAL_ERROR "Qt version ${QUAZIP_QT_MAJOR_VERSION} is not supported")
- endif()
diff --git a/dev-libs/quazip/quazip-1.1.ebuild b/dev-libs/quazip/quazip-1.1.ebuild
deleted file mode 100644
index 491c9969ee34..000000000000
--- a/dev-libs/quazip/quazip-1.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-# Note: Please check if upstream want 2.x and so on to be slotted when released.
-if ver_test ${PV} -ge 2.0 ; then
- # Sanity check to avoid naive copy-bumps
- # Upstream expect parallel installation of 0.x/1.x/2.x/...
- # https://github.com/stachenov/quazip/blob/master/QuaZip-1.x-migration.md
- die "Upstream want 0.x, 1.x, 2.x, ... to be slotted"
-fi
-
-DESCRIPTION="Simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package"
-HOMEPAGE="https://stachenov.github.io/quazip/"
-SRC_URI="https://github.com/stachenov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="1"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
- sys-libs/zlib[minizip]
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-qt/qttest:5 )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1-conditional-tests.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DQUAZIP_ENABLE_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- use test && cmake_src_compile qztest
-}